Bug 220141 - Yum and hibernate don't mix
Yum and hibernate don't mix
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 00:42 EST by Trever Adams
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 14:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2006-12-19 00:42:16 EST
Description of problem:
There is a huge problem with hibernate in general on Linux. It will happen when
email is being fetched (and behind a conntrack firewall this leads to problems).
It hibernates when CPU/disk activity is high, etc.

In particular, if it hibernates while yum is active, yum hangs on resume because
the locks are stale. So, now I have a bunch of new apps with the old crap not
cleaned out. I am not sure how this should be fixed, but it is a problem with
yum, evolution (due to conntrack NEW/INVALID rejections on inbound, but not
outbound), and I am sure other apps.

Version-Release number of selected component (if applicable):
yum-3.0.1-6.fc7


How reproducible:
Only have let it happen once, and that was an accident. I imagine this is every
time.
Comment 1 Jeremy Katz 2007-04-25 15:00:08 EDT
What type of firewall rules are you running with?
Comment 2 Trever Adams 2007-04-25 16:58:07 EDT
Ok, the firewall rules are partially a redherring, because yum actually has
problems with the rpm locks as they are stale. The firewall rules I have only
allow CONNECTED, RELATED inbound, other than a few other rules. It specifically
rejects NEW, INVALID. However, these are on the router, on the individual box,
it is open.
Comment 3 Jeremy Katz 2007-04-25 17:20:16 EDT
I've definitely suspended while yum is running (not exactly on purpose, but so
it goes :-) and when I've resumed the box one of the following has happened:
1) If packages were in the middle of downloading, there's a download error and
the install aborts.  Rerunning yum update after my network connection comes back
is fine for this case
2) Packages were in the middle of installing; everything is downloaded here and
I continue to get updates applying after resuming.

I haven't ever seen yum just hang on a resume.  If you can get this to happen,
please attach an strace of what things look like on resume (or even better,
across the suspend/resume)
Comment 4 Trever Adams 2007-04-25 19:23:57 EDT
Maybe the bug has been fixed. #2 caused me to get stale rpm locks and it would
abort. This bug is six months old now. I am not going to try to deliberately
trip it. How long did you leave the machine hibernated? I think mine was close
to 24 hours.
Comment 5 Jeremy Katz 2007-04-26 14:27:46 EDT
Normally just time to/from work, but occasionally for longer flights or a few
days on weekends.  I suspect what you might have hit were some of the futex()
bugs in the FC6 kernel (and the first update or so) which led to weirdness with yum.

Note You need to log in before you can comment on or make changes to this bug.