Bug 220152 - Yum remove the old kernel
Yum remove the old kernel
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 05:51 EST by Frank Büttner
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 06:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2006-12-19 05:51:07 EST
Description of problem:
When I run yum update and there will be an new kernel, thate the old one will be
removed. This is very bad, because when the new one don't boot. Than you have an
big problem and must use the rescue CD to fix it manual.

Version-Release number of selected component (if applicable):
yum-3.0.1-2.fc6

How reproducible:


Steps to Reproduce:
1. yum update
 
Actual results:
When an new kernel is found the old one will be removed

Expected results:
That the old one will be hold.

Additional info:
=============================================================================
Installing:
 kernel                  i686       2.6.18-1.2868.fc6  updates      16 M
 kernel-devel            i686       2.6.18-1.2868.fc6  updates     4.6 M
 kmod-ntfs               i686       2.1.27-2.2.6.18_1.2868.fc6  livna           
  107 k
Updating:
 aumix                   i386       2.8-11.fc6       extras             76 k
 kernel-headers          i386       2.6.18-1.2868.fc6  updates     700 k
 scim-libs               i386       1.4.4-36.fc6     updates     463 k
Removing:
 kernel                  i686       2.6.18-1.2798.fc6  installed          44 M

Transaction Summary
=============================================================================
Comment 1 Seth Vidal 2006-12-19 06:00:16 EST
this is the installonlyn plugin and it always leaves the last 2 kernels and the
running kernel.

If you want to disable it go into /etc/yum/plugins and disable it.

Note You need to log in before you can comment on or make changes to this bug.