Bug 22016 - Some cards unusable in TCIC/Databook PCMCIA readers
Some cards unusable in TCIC/Databook PCMCIA readers
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-10 05:54 EST by John Bass
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 18:41:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bass 2000-12-10 05:54:37 EST
in cardmgr/probe.c:tcic_probe_at() the function first attempts to
determine if any device is in the slot ... and loops checking first
8 words and aborts if ANY are 0xfffff.

This is incorrect, since some un-initialized devices may have one or
more ports returning 0xffff ... in particular Aironet PC4800 do, and
are unusable in slots managed by tcic controllers (like Databook chips).

The correct choice would be to check for ALL ports returning 0xffff:

    /* Anything there? /*
    for (i = 0; i < 0x10; i+=2)
        if (tcic_getw(base, i) != 0xffff)
            break;
    /* if all registers/ports are floating do an error return - JBass */
    if(i == 0x10)
        return -1;
Comment 1 Alan Cox 2003-06-05 18:41:02 EDT
Current errata use the kernel pcmcia not the add on
Comment 2 John Bass 2003-06-05 23:10:51 EDT
This remains broken in both RH8 and RH8 using stock install and no add-on
software. In particular Aironet PC4800 cards which worked in previous releases
will no longer configure in the reader/adapter cards with DataBook chips, that
worked fine in previous releases.

I guess I need therefor to re-create the bug report in both RH8 and RH9?????

Note You need to log in before you can comment on or make changes to this bug.