Bug 220175 - /proc for user process becomes owned by root after signal
/proc for user process becomes owned by root after signal
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
: 220176 (view as bug list)
Depends On:
Blocks: 173278
  Show dependency treegraph
 
Reported: 2006-12-19 10:05 EST by Mike Cvet
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 20:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Cvet 2006-12-19 10:05:43 EST
Downstream bug for Frysk: http://sourceware.org/bugzilla/show_bug.cgi?id=3754

We're just looking for clarification on what's happening here:

Single threaded process, running normally:

mcvet@warbird:/proc/20911 >> ls -l
total 0
dr-xr-xr-x 2 mcvet mcvet 0 Dec 18 16:23 attr
-r-------- 1 mcvet mcvet 0 Dec 18 16:23 auxv
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 cmdline
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 cpuset
lrwxrwxrwx 1 mcvet mcvet 0 Dec 18 16:23 cwd -> /home/mcvet/workspace/build/
frysk-core/frysk/bindir
-r-------- 1 mcvet mcvet 0 Dec 18 16:23 environ
lrwxrwxrwx 1 mcvet mcvet 0 Dec 18 16:23 exe -> /home/mcvet/stepper
dr-x------ 2 mcvet mcvet 0 Dec 18 16:23 fd
-rw-r--r-- 1 mcvet mcvet 0 Dec 18 16:23 loginuid
-r-------- 1 mcvet mcvet 0 Dec 18 16:23 maps
-rw------- 1 mcvet mcvet 0 Dec 18 16:23 mem
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 mounts
-r-------- 1 mcvet mcvet 0 Dec 18 16:23 mountstats
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 numa_maps
-rw-r--r-- 1 mcvet mcvet 0 Dec 18 16:23 oom_adj
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 oom_score
lrwxrwxrwx 1 mcvet mcvet 0 Dec 18 16:23 root -> /
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 schedstat
-r-------- 1 mcvet mcvet 0 Dec 18 16:23 smaps
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 stat
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 statm
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 status
dr-xr-xr-x 3 mcvet mcvet 0 Dec 18 16:23 task
-r--r--r-- 1 mcvet mcvet 0 Dec 18 16:23 wchan

Then the process is sent a signal:

$ kill -11 20911

With the process blocked after receiving the signal:


mcvet@warbird:/proc/20911 >> ls -l
ls: cannot read symbolic link cwd: Permission denied
ls: cannot read symbolic link root: Permission denied
ls: cannot read symbolic link exe: Permission denied
total 0
dr-xr-xr-x 2 mcvet mcvet 0 Dec 18 16:23 attr
-r-------- 1 root root 0 Dec 18 16:23 auxv
-r--r--r-- 1 root root 0 Dec 18 16:23 cmdline
-r--r--r-- 1 root root 0 Dec 18 16:23 cpuset
lrwxrwxrwx 1 root root 0 Dec 18 16:23 cwd
-r-------- 1 root root 0 Dec 18 16:23 environ
lrwxrwxrwx 1 root root 0 Dec 18 16:23 exe
dr-x------ 2 root root 0 Dec 18 16:23 fd
-rw-r--r-- 1 root root 0 Dec 18 16:23 loginuid
-r-------- 1 root root 0 Dec 18 16:23 maps
-rw------- 1 root root 0 Dec 18 16:23 mem
-r--r--r-- 1 root root 0 Dec 18 16:23 mounts
-r-------- 1 root root 0 Dec 18 16:23 mountstats
-r--r--r-- 1 root root 0 Dec 18 16:23 numa_maps
-rw-r--r-- 1 root root 0 Dec 18 16:23 oom_adj
-r--r--r-- 1 root root 0 Dec 18 16:23 oom_score
lrwxrwxrwx 1 root root 0 Dec 18 16:23 root
-r--r--r-- 1 root root 0 Dec 18 16:23 schedstat
-r-------- 1 root root 0 Dec 18 16:23 smaps
-r--r--r-- 1 root root 0 Dec 18 16:23 stat
-r--r--r-- 1 root root 0 Dec 18 16:23 statm
-r--r--r-- 1 root root 0 Dec 18 16:23 status
dr-xr-xr-x 3 mcvet mcvet 0 Dec 18 16:23 task
-r--r--r-- 1 root root 0 Dec 18 16:23 wchan

Same story for /proc/$$/tasks/$$/.
Comment 1 Mike Cvet 2006-12-19 10:19:20 EST
*** Bug 220176 has been marked as a duplicate of this bug. ***
Comment 2 Roland McGrath 2006-12-19 13:08:21 EST
show status contents
i suspect you mean "after death" (zombie statw)
Comment 3 Roland McGrath 2006-12-19 14:41:08 EST
that change is normal when a coredump signal kills the process,
cf mm->dumpable flag overloaded for security and for coredump multiple exclusion

Note You need to log in before you can comment on or make changes to this bug.