Bug 220187 - Conflicts with gdesklets
Conflicts with gdesklets
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdeskcal (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-12-19 11:12 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.0-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-18 18:44:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2006-12-19 11:12:28 EST
gdesklets - 0.35.4-1.fc6.i386
  => Package conflicts with: gdeskcal - 1.0-9.fc6.noarch
  File conflict with: /usr/share/locale/ru/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/sv/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/de/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/hr/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/fr/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/cs/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/ja/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/ko/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/ar/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/is/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/nl/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/zh_TW/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/lt/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/pl/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/el/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/es/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/zh_CN/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/sr/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/vi/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/bg/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/he/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/hu/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/uk/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/tr/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/it/LC_MESSAGES/gdesklets.mo
  File conflict with: /usr/share/locale/fi/LC_MESSAGES/gdesklets.mo
Comment 1 Paul F. Johnson 2007-02-15 20:45:52 EST
Not sure on this. Is it possible to separate out the lang files into their own
subpackage?
Comment 2 Michael Schwendt 2007-02-16 04:50:32 EST
That doesn't solve the conflict. The proper fix would be to name
the message objects gdeskcal.mo not gdesklets.mo. Why does gdeskcal
use the %name of gdesklets?
Comment 3 Michael Schwendt 2007-02-16 04:51:37 EST
And renaming them needs a patch for the source code, of course.
Comment 4 Paul F. Johnson 2007-02-16 05:26:52 EST
They're the same IIRC.
Comment 5 Michael Schwendt 2007-02-16 06:36:09 EST
They don't even have the same size.
Comment 6 Michael Schwendt 2007-02-26 07:19:28 EST
Ping.

If you like, I would simply fix this myself.
Comment 7 Michael Schwendt 2007-03-02 11:08:00 EST
* the translations don't work at all, because gdeskcal 1.0 doesn't
initialise gettext correctly to look in /usr/share/local

* your patch to the About dialog does not display it

Upstream has released 1.01 which include my submitted patches
and/or modified fixes for these issues. The .mo files have been
renamed to gdeskcal, too.
Comment 8 Michael Schwendt 2007-03-18 18:44:16 EDT
I've fixed this in CVS. Syncmail has notified you about the commit.

Build requests for FC-6 and FC-5 will follow tomorrow.

Note You need to log in before you can comment on or make changes to this bug.