Bug 220197 - crash at boot: Vector 700; eventual sig: 5
crash at boot: Vector 700; eventual sig: 5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 11:46 EST by John Reiser
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 11:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
photo of VGA console at 3-minute loop (102.20 KB, image/jpeg)
2006-12-19 11:46 EST, John Reiser
no flags Details
photo of VGA console at 3-minute loop (128.55 KB, image/jpeg)
2006-12-20 10:46 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2006-12-19 11:46:20 EST
Description of problem: crash during boot


Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2885.fc7

How reproducible: always


Steps to Reproduce:
1. "boot: linux" using the 2006-12-19 (Tuesday) rescue CD for PowerPC
2.
3.
  
Actual results:
Eventual 3 minute loop with:
  Unable to handle kernel paging request for data at address 0x0
  Faulting instruction address: 0xc0126659
  Oops: Kernel access of bad area, sig: 11 [#1]
  <traceback omitted>
but there was an earlier message that did not stop:
  Vector: 300 (Data Access) at [dffc3d20]
      pc: c0126658: list_del+0x14/0x88
      lr: c008ec49: cache_alloc_refill+0x178/0x55c
      sp: dffc3dd0
     msr: 1032
just before "hdb: Enabling Ultra DMA2".


Expected results: successful boot


Additional info: I will attach photo of console, but some interesting lines
probably scrolled off the top when the "Vector: 300..." did not pause.  Hardware
is Apple Macintosh mini PowerPC 32-bit.
Comment 1 John Reiser 2006-12-19 11:46:20 EST
Created attachment 144013 [details]
photo of VGA console at 3-minute loop
Comment 2 John Reiser 2006-12-20 10:40:28 EST
2006-12-20 (Wednesday) still crashes, perhaps a bit further on: Vector 700,
eventual sig: 5.  Will attach photo of VGA console.
Comment 3 John Reiser 2006-12-20 10:46:15 EST
Created attachment 144112 [details]
photo of VGA console at 3-minute loop

Vector 700; sig: 5
pc: cache_free_debugcheck+0x168/0x228

kernel BUG at mm/slab.c:2878!
Oops: Exception in kernel mode: sig: 5 [#1]

cache_free_debugcheck+0x28/0x228
kfree+0x88/0x104
block_uevent+0x128/0x1b8
kobject_uevent_env+0x268/0x470
register_disk+0x1d8+0x248
add_disk+0x58/0x74
ide_disk_probe+0x878/0x8b4
...
Comment 4 John Reiser 2007-01-09 14:27:32 EST
Still happens with kernel-2.6.19-1.2906.fc7 on today's rescue CD (2007-01-09).
The traceback shows the same subroutines, although the addresses have moved a
little.
Comment 5 David Woodhouse 2007-03-26 05:40:46 EDT
There was a memory corruption bug which affected all architectures -- allocating
only a single page when more than that was requested. The ide-pmac driver has an
allocation of 0x1020 bytes, which showed this error quite nicely. It looks like
that's what you were seeing. It's fixed now -- please try again.
Comment 6 John Reiser 2007-03-27 11:28:28 EDT
Fixed in the PowerPC rescue CD-ROM of 2007-03-26 with sha1sum:
62fd25c4279260e28448aa4ece5737f43e4ce9f7  FC-development-ppc-rescuecd.iso
"boot: linux" gets at least as far as choosing language, keyboard, install
method, dhcp+ipv4, no ipv6, mirror, directory, etc.

Note You need to log in before you can comment on or make changes to this bug.