Bug 220202 - git-clone output is too verbose
git-clone output is too verbose
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: git-core (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
http://marc.theaimsgroup.com/?l=git&m...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 12:10 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 12:46:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
enable git clone --quiet http:// (812 bytes, patch)
2007-03-20 12:45 EDT, Chris Wright
no flags Details | Diff

  None (edit)
Description Need Real Name 2006-12-19 12:10:34 EST
Description of problem:
Since my last update "git clone" command it's just too verbose, it prints
houndreds of lines like:
[...]
got 41636430e67e4ef72965dd16c394fbf4318854b6
walk e75562bfdedb9daa31670b6cce805a19706e7c16
got cba6c5871cca721c134430f4b27beaf3192184a4
[...]

I got the same result cloning http://www.gnome.org/~alexl/git/gvfs.git/ and
http://ktown.kde.org/~zrusin/dev/kimagefx.git

Notice that the cloning works ok, just the output is weird


Version-Release number of selected component (if applicable):
git-1.4.4.2-2.fc6.src.rpm. It didn't happen with previous versions.

How reproducible:
just type: git-clone http://ktown.kde.org/~zrusin/dev/kimagefx.git
Comment 1 Josh Boyer 2007-02-14 08:15:47 EST
This is a result of a change in how upstream git works over http.  You should
file a bug report with the upstream git maintainers to correct this.  Note,
however, they discourage use of git over http in general as it is not an
efficient protocol for git.
Comment 2 Need Real Name 2007-02-15 13:02:34 EST
Reported (and patch proposed) to upstream
Comment 3 Chris Wright 2007-03-19 19:04:35 EDT
I just pinged Junio to see if he's interested in taking such a patch.  If
he's not, I'll close this as NOTABUG.
Comment 4 Chris Wright 2007-03-20 12:45:11 EDT
Created attachment 150508 [details]
enable git clone --quiet http://

This patch was sent upstream to give a quiet option for http clones
Comment 5 Chris Wright 2007-03-20 12:46:32 EDT
Junio took this patch, so it's now fixed upstream.  Should make the next release.

Note You need to log in before you can comment on or make changes to this bug.