Bug 220246 - [RHEL 5.0] qla3xxx panics when eth1 (qla3xxx) is sending pings
[RHEL 5.0] qla3xxx panics when eth1 (qla3xxx) is sending pings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Konrad Rzeszutek
Brian Brock
: EasyFix
Depends On:
Blocks: 216985 222067
  Show dependency treegraph
 
Reported: 2006-12-19 16:24 EST by Konrad Rzeszutek
Modified: 2010-03-14 17:27 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 09:22:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch back-ported from BZ 217546. (440 bytes, patch)
2007-01-04 13:58 EST, Konrad Rzeszutek
no flags Details | Diff

  None (edit)
Description Konrad Rzeszutek 2006-12-19 16:24:36 EST
+++ This bug was initially created as a clone of Bug #217546 +++

QLA3XXX dies when a ping test is performed.

-- Additional comment from ron.mercer@qlogic.com on 2006-12-19 13:53 EST --
Konrad,
Have you pushed the fixes for this bug into RHEL5, or should we do it?
Ron

-- Additional comment from konradr@redhat.com on 2006-12-19 16:19 EST --
Ron,

I have not pushed the updates to RHEL5. Let me clone this BZ for RHEL5 and ask
RH management to make an exception to get this in.

Have the fixes that are in this BZ been pushed upstream? If so, do you have the
GIT commit?
Comment 1 Ron Mercer 2006-12-19 17:18:56 EST
I've pushed the changes upstream, but they haven't been committed yet. Having 
some trouble getting attention probably because of the release cycle for 
2.6.20.  I resent them this morning.  Take a look at:

http://www.spinics.net/lists/netdev/msg21646.html

Patch 4/5 is the ping test patch.  Patch 3/5 adds delay to NVRAM access and is 
in the code you have also.  The other 3 patches are for 4032 chip support 
which we can tackle later.
Comment 2 Konrad Rzeszutek 2006-12-20 10:30:19 EST
Jay,

What are your thoughts to have this as a blocker for RHEL5? The patches are for
the driver only and they are being pushed upstream. The test-case that
reproduces this panic is quite simple:

#!/bin/bash
COUNT=1
while (true)
do
 expr $COUNT \> 65500  1>/dev/null
 if [ "$?" == 0 ]; then
        exit 0;
 fi
 COUNT=`expr $COUNT + 1` 1>/dev/null
 ping ibm-x232.lab.boston.redhat.com -c 5 -s$COUNT 1>/dev/null 2>/dev/null &
done

or should this wait until RHEL5 U1?
Comment 3 Andrius Benokraitis 2007-01-04 12:15:42 EST
Konrad, will dependent bug 217546 fix this issue?
Comment 4 Konrad Rzeszutek 2007-01-04 13:58:23 EST
Created attachment 144831 [details]
Patch back-ported from BZ 217546.
Comment 5 Konrad Rzeszutek 2007-01-04 14:00:34 EST
Andrius,

The BZ 217546 is a RHEL4 U5 bug. This BZ is for RHEL5. To answer your question,
fixing 217546 will NOT fix this issue. But the patch in comment #4 will fix this
issue.
Comment 6 Konrad Rzeszutek 2007-01-04 14:02:54 EST
Raising the flags to make the management aware of this BZ.
Comment 7 Tom Coughlan 2007-01-04 14:15:36 EST
devel_ack. This fixes an easy-to-reproduce panic. The one-line fix is entirely
confined to this (new) driver in RHEL 5.
Comment 9 Konrad Rzeszutek 2007-01-04 14:19:49 EST
Patch has been posted on RHKL.
Comment 10 Jay Turner 2007-01-04 14:30:11 EST
QE ack for RHEL5.
Comment 11 Andrius Benokraitis 2007-01-04 14:52:36 EST
Konrad, does this solve recently created bug 221328?
Comment 12 Konrad Rzeszutek 2007-01-04 15:09:51 EST
(In reply to comment #11)
> Konrad, does this solve recently created bug 221328?

No.
Comment 15 RHEL Product and Program Management 2007-01-10 11:41:48 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 16 Don Zickus 2007-01-10 18:58:37 EST
in 2.6.18-1.3002.el5
Comment 17 Jay Turner 2007-01-10 22:09:14 EST
QE ack for RHEL5.  Fix confirmed with 2.6.18-1.3002.el5:

$ grep -r "CONFIG_QLA3XXX" 2.6.18-1.3002.el5-*
2.6.18-1.3002.el5-i686/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-ia64/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-kdump-ppc64/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-PAE-i686/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-ppc64/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-x86_64/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-xen-i686/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-xen-ia64/.config:# CONFIG_QLA3XXX is not set
2.6.18-1.3002.el5-xen-x86_64/.config:# CONFIG_QLA3XXX is not set
Comment 18 Jay Turner 2007-01-15 09:22:27 EST
kernel-2.6.18-1.3002.el5 included in 20070111.1 and 20070112.3.
Comment 19 Ryan Lerch 2008-08-20 18:21:42 EDT
Does this issue require documentation in the RHEL5.3 release notes?

If so, please provide a release notes draft in the "Release Notes" field of
this bug. thanks!

Note You need to log in before you can comment on or make changes to this bug.