Bug 220256 - kexec fails on ia64 box because it cannot allocate memory
kexec fails on ia64 box because it cannot allocate memory
Status: CLOSED DUPLICATE of bug 220276
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 17:14 EST by Akira Imamura
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-20 08:21:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira Imamura 2006-12-19 17:14:16 EST
Description of problem:
kexec fails because it cannot allocate memory. Consequently, kdump service
always fails to start up.

Version-Release number of selected component (if applicable):
kexec-tools-1.101-151.el5

How reproducible:
Always

Steps to Reproduce:
1. Run "service kdump start" or just run "kexec <options> <args>"
2.
3.
  
Actual results:
kexec fails with the following error.

Cannot malloc 984921900322816 bytes: Cannot allocate memory

Expected results:
kexec succeeds, and kdump service starts up.

Additional info:
Comment 1 Neil Horman 2006-12-20 08:07:46 EST
Jarod or Akira, Can you provide me with access information to the SGI machine
(or any sufficiently large ia64 box), so that I can debug this please?

Thanks!
Comment 2 Neil Horman 2006-12-20 08:21:34 EST
never mind, jarod already got this fixed in -153.el5

*** This bug has been marked as a duplicate of 220276 ***

Note You need to log in before you can comment on or make changes to this bug.