Bug 220269 - upgraded kernel panics
upgraded kernel panics
Status: CLOSED DUPLICATE of bug 211030
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
http://otthon.csi.hu/mw/kepernyo.jpeg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 18:55 EST by Mate Wierdl
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 01:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
picture of screen when trying to boot (1.58 MB, image/jpeg)
2006-12-19 18:55 EST, Mate Wierdl
no flags Details
the last screen of the unsuccessful boot (1.58 MB, image/jpeg)
2007-01-22 14:25 EST, Mate Wierdl
no flags Details
movie of the whole unsuccesful boot (16.17 MB, video/quicktime)
2007-01-22 14:36 EST, Mate Wierdl
no flags Details

  None (edit)
Description Mate Wierdl 2006-12-19 18:55:33 EST
Description of problem:

Eversince I upgraded the kernel on my system after 2.6.17-1.2187_FC5, the system
cannot boot with the new kernel.  I am attaching the photo I took of my screen
after trying to reboot with the newest kernel, 2.6.18-1.2257.fc5.  It is also at

http://otthon.csi.hu/mw/kepernyo.jpeg

Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2257.fc5

How reproducible:

always


Steps to Reproduce:
1. make sure grub will boot kernel-2.6.18-1.2257.fc5
2. reboot
3.
  
Actual results:

Kernel panics, and so the computer cannot boot.

Expected results:

Proper reboot.


Additional info:

The system is an AMD x86_64.  The hardware has not changed in more than a year.
The output of lshal is at

http://otthon.csi.hu/mw/thales_lshal.txt

I have a similar system at home, and there there is no problem running the newer
kernels.  The output of lshal for my homebox is at 

http://otthon.csi.hu/mw/otthon_lshal.txt

As you see, on the homebox I am running kernel 2.6.18-1.2239.fc5 which is not 
yet the latest, but my office computer panicked with this 2.6.18-1.2239.fc5
also.
Comment 1 Mate Wierdl 2006-12-19 18:55:36 EST
Created attachment 144057 [details]
picture of screen when trying to boot
Comment 2 Mate Wierdl 2007-01-20 06:55:15 EST
It has been a month since I posted this severe problem, and I do not see any
reaction.  I am just sending this in case people at RH/FC just forgot about it.
Comment 3 Konrad Rzeszutek 2007-01-22 12:33:34 EST
Can you remove "rhgb quiet" from the bootup parameters? That gives a lot more
details.

To do that, hit 'space' when GRUB shows up, hit 'e' on the kernel, scroll down
to kernel .. line, and hit 'e' again. Remove the rhgb and quite. Hit Enter and
then 'b'.
Comment 4 Mate Wierdl 2007-01-22 14:25:38 EST
Created attachment 146211 [details]
the last screen of the unsuccessful boot

The last screen after I removed the "rhgb quiet" option
Comment 5 Mate Wierdl 2007-01-22 14:36:19 EST
Created attachment 146212 [details]
movie of the whole unsuccesful boot

This is a MOV file taken with my digital camera.
Comment 6 Mate Wierdl 2007-01-22 14:38:41 EST
Thx for looking into this.  If there is a better way to capture the bootscreen,
let me know.  Uploading a 16M MOV file does not look very efficient.
Comment 7 Mate Wierdl 2007-01-30 01:21:40 EST
Here is a fix to the problem:

mkinitrd -v -f --preload=raid456 /boot/initrd-2.6.18-1.2257.fc5.img
2.6.18-1.2257.fc5

The change I noticed after kernel-2.6.17-1.2187_FC5 is that the raid5.ko module
did not exist anymore, but only the raid456.ko module.  Since my root partition
is on a raid5 array, the bug bit me.  

Of course, I do not want to recompile initrd after every kernel upgrade, so
please either use the --preload=raid456 option at RH or let me know of another
hopefully permanent fix.



Comment 8 Mate Wierdl 2007-03-13 01:22:32 EDT
I just installed the latest kernel

kernel-2.6.19-1.2288.2.4.fc5

and the bug is still there.  So this thing does not bite anybody else with raid5?

How are the kernels for FC6? 

I do not dare to upgrade to FC6 because of the bug.  Will I be able to boot into
runlevel 1, and run the initrd fix? 
Comment 9 Mate Wierdl 2007-03-13 01:29:09 EDT

*** This bug has been marked as a duplicate of 211030 ***

Note You need to log in before you can comment on or make changes to this bug.