Bug 220270 - Unable to run enable desktop-effects
Unable to run enable desktop-effects
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-19 19:08 EST by Adam Huffman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 15:08:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log when Intel chipset is enabled (66.97 KB, text/plain)
2006-12-19 19:08 EST, Adam Huffman
no flags Details
xorg.conf (1.29 KB, text/plain)
2006-12-26 12:13 EST, Adam Huffman
no flags Details
X log file without any xorg.conf (69.78 KB, text/plain)
2006-12-26 12:33 EST, Adam Huffman
no flags Details
glxinfo output (3.72 KB, text/plain)
2007-01-25 10:56 EST, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2006-12-19 19:08:33 EST
Description of problem:
I am unable to use desktop-effects to enable compiz on a Vaio SZ3, running an up
to date FC6.  It soon after inatallation, but with subsequent updates appears to
be broken now.  Compiz runs happily when I have the Nvidia chipset enabled (and
the proprietary driver) but not with the Intel chipset.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-10.fc6

How reproducible:
Every time

Steps to Reproduce:
1. run 'desktop-effects'
2.
3.
  
Actual results:
There is an error message and compiz is not enabled

Expected results:
Compiz should be enabled

Additional info:

This could be a compiz bug, I suppose.
Comment 1 Adam Huffman 2006-12-19 19:08:33 EST
Created attachment 144059 [details]
X log when Intel chipset is enabled
Comment 2 Matěj Cepl 2006-12-22 09:56:09 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachment using the bugzilla file attachment
link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Matěj Cepl 2006-12-22 09:56:32 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachment using the bugzilla file attachment
link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Adam Huffman 2006-12-26 12:13:31 EST
Created attachment 144374 [details]
xorg.conf

xorg.conf, as requested
Comment 5 Adam Huffman 2006-12-26 12:33:00 EST
Created attachment 144375 [details]
X log file without any xorg.conf

This is the log file when xorg.conf has been renamed
Comment 6 Adam Huffman 2006-12-26 12:34:17 EST
I have booted without any xorg.conf file and it is still impossible to enable
desktop-effects.
Comment 7 Adam Jackson 2007-01-24 16:47:14 EST
aiglx appears to be initializing fine.  The question is why compiz doesn't run.
 You haven't specified whether compiz just doesn't start, or whether it fails to
render correctly.

What output do you get from running:

LIBGL_ALWAYS_INDIRECT=1 glxinfo

?
Comment 8 Adam Huffman 2007-01-25 10:56:33 EST
Created attachment 146571 [details]
glxinfo output

Output of LIBGL_ALWAYS_INDIRECT=1 glxinfo as requested
Comment 9 Adam Huffman 2007-01-25 10:57:34 EST
Comment to make bugzilla happy
Comment 10 Adam Jackson 2007-04-10 18:38:31 EDT
Hm, so aiglx looks like it works.  Does compiz print any error messages, or does
it just not render properly, or does the desktop effects applet revert you to
metacity after the timeout, or... ?
Comment 11 Adam Huffman 2007-04-10 20:13:40 EDT
Compiz prints some messages and then the applet reverts to metacity:

compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0
Comment 12 Adam Huffman 2007-04-25 17:33:37 EDT
I've upgraded the machine in question to rawhide, and desktop-effects is working
with the newer drivers.
Comment 13 Adam Jackson 2007-04-26 15:08:46 EDT
Marking worksforme as per comment #12.  Please reopen if this comes back.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.