Bug 220283 - RHEL5-B2:"window not responding" message displayed when trying to close gnome-terminal
RHEL5-B2:"window not responding" message displayed when trying to close gnome...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: metacity (Show other bugs)
5.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks: 223278
  Show dependency treegraph
 
Reported: 2006-12-20 00:57 EST by Raghavendra Biligiri
Modified: 2014-06-18 05:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-1146
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:37:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of the pop-up message displayed (177.91 KB, image/x-png)
2006-12-20 00:59 EST, Raghavendra Biligiri
no flags Details

  None (edit)
Description Raghavendra Biligiri 2006-12-20 00:57:00 EST
Description of problem:
On RHEL5-B2(kernel-2.6.18-1.2839.el5),when we try to close the gnome-terminal 
by clicking the "Close button (x)" , we get a pop-up message that the window we 
are trying to close is not responding.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2839.el5
gnome-terminal(version 2.16.0)

How reproducible:


Steps to Reproduce:
1.Install RHEL5-B2 x86_64(kernel-2.6.18-1.2839.el5)
2.Open a gnome-terminal
3.Open a tab (Shift + Ctrl + T)
4.Try to close the window by clicking "X" (right hand corner) button.
  
Actual results:
"window not responding" message displayed when trying to close gnome-terminal

Expected results:
gnome-terminal should exit without any error messages

Additional info:
Attached the snapshot of the pop-up message displayed
Comment 1 Raghavendra Biligiri 2006-12-20 00:59:44 EST
Created attachment 144074 [details]
snapshot of the pop-up message displayed
Comment 2 Larry Troan 2007-01-03 14:10:58 EST
NOT A BLOCKER:
Per telecon with Sue Denham (RH), Larry Troan (RH), John Hull (Dell) and Dale
Kaisner (Dell) on 1/02/07. 

While Dell would like to see this fixed for GA, it is NOT a BLOCKER.
Comment 3 Amit Bhutani 2007-01-24 10:06:05 EST
Tracking this against RHEL 5.1.0 as the chances of this making RHEL 5.0.0 at
this point appear to be slim to none.
Comment 4 Raghavendra Biligiri 2007-01-25 07:58:46 EST
Issue not reproducible on RHEL5-RC-Snapshot7(kernel-2.6.18-1.3002.el5).
Comment 5 Amit Bhutani 2007-01-25 09:09:37 EST
Closing this issue as a WFM since it's not reproducible anymore.
Comment 6 Raghavendra Biligiri 2007-04-02 11:25:08 EDT
Reopening this issue since it is reproducible on RHEL5-Gold x86_64(kernel-
2.6.18-8.el5).
This is a known issue about metacity and more details about the issue can be 
found at http://bugzilla.gnome.org/show_bug.cgi?id=348305
metacity-2.16.2 fixes the issue.(RHEL5-Gold has metacity-2.16.0-8.el5)
Comment 7 Behdad Esfahbod 2007-05-14 20:17:35 EDT
I would reassign to metacity.  There's not much to do in gnome-terminal
Comment 8 John Feeney 2007-05-15 16:35:43 EDT
Okay, re-assigning to metacity. 
Comment 9 Søren Sandmann Pedersen 2007-05-29 17:18:21 EDT
Devel ack; the explanation in the gnome bug sounds very plausible to me.
Comment 11 Lauri Nurmi 2007-09-11 11:57:24 EDT
This bug is indeed metacity-related (rather than gnome-terminal), and still
present (on 64-bit CentOS 5). It can be reproduced with various programs that
open a dialog after clicking the close button -- gedit, and OpenOffice, for example.

Quite a small but annoying feature.
Comment 14 Larry Troan 2007-12-05 10:12:00 EST
Expected to be in RHEL5.2. 

Accepted to RHEL5 fastrack channel (not errata channel) on RHN so package should
be available via that RHN channel prior to 5.2 availability. 
Comment 17 errata-xmlrpc 2007-12-20 11:37:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1146.html

Note You need to log in before you can comment on or make changes to this bug.