Bug 220317 - The version marked as 1.9.18 is not 1.9.18, newer version available
The version marked as 1.9.18 is not 1.9.18, newer version available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hnb (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 07:44 EST by Tomas Janousek
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 07:13:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed srpm (146.10 KB, application/x-rpm)
2006-12-20 07:44 EST, Tomas Janousek
no flags Details

  None (edit)
Description Tomas Janousek 2006-12-20 07:44:32 EST
The rpm version is 1.9.18, but the sources are some old 1.9.18-pre. The project
seems unmaintained for quite a long time so I think we could probably take the
current CVS sources (which are more than 2 years old anyway) and release an
update. They fix some issues. I'm attaching my srpm.
Comment 1 Tomas Janousek 2006-12-20 07:44:32 EST
Created attachment 144093 [details]
proposed srpm
Comment 2 Dominik 'Rathann' Mierzejewski 2006-12-20 08:43:30 EST
Why do you claim the sources are 1.9.18-pre?
Comment 3 Tomas Janousek 2006-12-20 08:53:38 EST
Because there was a tarball of 1.9.18-pre6 available to download a year or two
ago and the changelog contained more entries than your one does. (and still less
entries than the cvs changelog does, which is, if i understand correctly, still
not final 1.9.18)
Comment 4 Dominik 'Rathann' Mierzejewski 2006-12-21 17:10:11 EST
I don't know which 1.9.18-pre6 tarball you're talking about, but the one in
http://hnb.sourceforge.net/.files/ is definitely older than full 1.9.18 in the
same directory. There are no newer tarballs.
Comment 5 Tomas Janousek 2006-12-22 03:30:49 EST
This is a real fun. The 1.9.18 is lacking half the features of pre6, according
to changelog/diff. So I have no clue what is the right version and what to do :).
Comment 6 Dominik 'Rathann' Mierzejewski 2007-01-28 11:22:19 EST
I compared all the tarballs in that directory and it seems that pre7 tarball
contains the newest code. Can you confirm that it has the missing features?
Comment 7 Dominik 'Rathann' Mierzejewski 2007-01-28 12:16:39 EST
OK, I've just found a patch in Debian package that seems to add some more
features and fixes some compiler warnings:
http://ftp.debian.org/debian/pool/main/h/hnb/hnb_1.9.18-3.diff.gz .
I can add that one, too.
Comment 8 Tomas Janousek 2007-01-28 13:47:37 EST
Well, pre7 isn't still as new as the CVS one. And the debian patch appears to
address different issues. I forked the project though, planning to do some
development of my wishes etc., so I probably don't care much anymore. Thanks for
the time you spent investigating, anyway.
Comment 9 Dominik 'Rathann' Mierzejewski 2007-01-28 17:12:10 EST
Having an active upstream is a good thing. I have no problem with switching to
your fork. However, I don't want to package a CVS snapshot of unknown origin. If
you have a website for your hnb fork somewhere and it has a tarball available,
I'll be happy to package that. I guess the original author has lost interest in
developing hnb. I haven't received any reply to my e-mails from him.
Comment 10 Tomas Janousek 2007-01-28 17:21:36 EST
Yeah, I haven't received reply to my mails (it might be more than 2 years now)
neither. I don't have a website yet, but I think I might create one after I
achieve a few goals and release a tarball. I will let you know.
Comment 11 Tomas Janousek 2007-09-07 07:13:16 EDT
I noticed that you switched to pre7 and applied the debian patch recently, so
I'm closing this report as it effectively fixes it.

Btw, the debian patch introduced a bug in editing -- the cursor no longer marks
the place where the logical cursor is, the highlight is always at the end of the
node. I found this when I was reviewing the patch for applying to my fork. This
is fixed in my tree.

And I finally managed to make some commits and release a version. It's available
at http://nomi.cz/download/releases/lhnb/

Note You need to log in before you can comment on or make changes to this bug.