Bug 2203316 - kstars crashes immediately on startup
Summary: kstars crashes immediately on startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kstars
Version: 38
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-05-11 21:05 UTC by Göran Uddeborg
Modified: 2023-09-11 01:16 UTC (History)
8 users (show)

Fixed In Version: kstars-3.6.6-1.fc38
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-11 01:16:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Göran Uddeborg 2023-05-11 21:05:30 UTC
When starting kstars, it immediately complains about the undefined symbol "timestamp" exits.

kstars-3.6.3-1.fc38.x86_64
libindi-2.0.1-3.fc38.x86_64


Reproducible: Always

Steps to Reproduce:
1. Run "kstars" in a terminal window.
Actual Results:  
kstars: symbol lookup error: kstars: undefined symbol: timestamp


Expected Results:  
A kstars window.

With a little googling I found this seems to be because of updates of libindi which requires an adjustment and rebuild of kstars.

https://www.indilib.org/forum/stellarmate/13041-how-to-download-kstars-available-in-the-latest-indi-for-use-with-raspi.html#90590

Comment 1 Fedora Update System 2023-09-02 11:57:48 UTC
FEDORA-2023-3ada07f606 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-3ada07f606

Comment 2 Fedora Update System 2023-09-03 02:22:50 UTC
FEDORA-2023-3ada07f606 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-3ada07f606`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-3ada07f606

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2023-09-11 01:16:55 UTC
FEDORA-2023-3ada07f606 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.