Bug 220361 - power button script acts of finding grep is ps list, not gnome-power-manager
power button script acts of finding grep is ps list, not gnome-power-manager
Status: CLOSED DUPLICATE of bug 215824
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 12:28 EST by Douglas Kilpatrick
Modified: 2015-03-04 20:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 09:56:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Kilpatrick 2006-12-20 12:28:22 EST
Description of problem:
  Comment does not match code.  I don't think that does what you think that 
does.
  
Actual results:
 The shutdown will be run only if the ps includes "grep" in the return 
results.

Expected results:
  The shutdown will be run only if gnome-power-manager isn't in the ps list.

Additional info:
  I think you meant
action=/bin/ps 
awwux | /bin/grep -q '[g]nome-power-manager'  || /sbin/shutdown -h now
Comment 1 Douglas Kilpatrick 2006-12-20 12:32:25 EST
Doh.  Refering to /etc/acpi/event/power.conf
Comment 2 Phil Knirsch 2007-05-16 09:56:28 EDT

*** This bug has been marked as a duplicate of 215824 ***

Note You need to log in before you can comment on or make changes to this bug.