Bug 220367 - Bug in autoconf falsely checking Xt for X11
Bug in autoconf falsely checking Xt for X11
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 13:37 EST by Leo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.59-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 04:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo 2006-12-20 13:37:58 EST
Description of problem:
The autoconf in FC6 will check libXt-devel for deciding window_system when it is
not necessary. For example in compiling Emacs with GTK, if libXt-devel is not
installed, the configure script generated by autoconf 2.59 won't be able to
detect the window_system while GTK Emacs doesn't link to libXt at all.

This bug seems to have been fixed in 2.60 see the change log:
Revision 1.22  - (view) (download) (annotate) - [select for diffs]
Sat Aug 12 18:33:46 2006 UTC (4 months, 1 week ago) by eggert
Branch: MAIN
CVS Tags: AUTOCONF-2_60a
Changes since 1.21: +1 -1 lines
Diff to previous 1.21

* lib/autoconf/libs.m4 (AC_PATH_X_DIRECT): Replace another
check for libXt by a check for libX11.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Leo 2006-12-20 13:38:58 EST
There is a discussion in Emacs devel list:

http://thread.gmane.org/gmane.emacs.devel/63924/focus=64013
Comment 2 Patrice Dumas 2007-03-29 04:33:39 EDT
This was already fixed (by Karsten), so I close

* Tue May 16 2006 Karsten Hopp <karsten....> 2.59-8
- try to link with libX11 instead of libXt

* Wed Feb 15 2006 Karsten Hopp <karsten....> 2.59-7
- XrmInitialize takes no argument (#181340)

* Mon Feb 06 2006 Karsten Hopp <karsten....> 2.59-6
- check for Xlib.h instead of Intrinsic.h to find X11 headers
  (#176379)

Note You need to log in before you can comment on or make changes to this bug.