Bug 220385 - pm-hibernate fails with "Cannot allocate memory"
pm-hibernate fails with "Cannot allocate memory"
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Cunningham
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-12-20 16:33 EST by Carl Roth
Modified: 2008-05-06 13:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 13:13:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Kernel dmesg output (36.83 KB, text/plain)
2007-07-19 23:21 EDT, Carl Roth
no flags Details

  None (edit)
Description Carl Roth 2006-12-20 16:33:57 EST
Description of problem:

When I use 'pm-hibernate', the system does not hibernate.  It goes through the
motions, but never writes its state to swap, and returns to the calling shell with

  /etc/pm/functions: line 196: echo: write error: Cannot allocate memory

Version-Release number of selected component (if applicable):

Using pm-utils-0.19-3

How reproducible:

Most of the time.  I've been able to get pm-hibernate to work intermittently,
but never twice in a row.

Steps to Reproduce:
1. Boot system to runlevel 5
2. Type 'pm-hibernate'
Actual results:

System returns after a short pause with an error message.

Expected results:

System should suspend and resume.

Additional info:

Here's a grab-bag of system details:

  * dual-core 2GHz P4 (hyperthreading, EM64T)
  * Intel 955 mobo (D955KBK)
  * ATI radeon X1800 video card (using ati-fglrx from livna.org)
  * 1GiB of RAM, 3GiB of swap
  * /etc/pm/config as follows (two sound devices to disable on suspend)

      SUSPEND_MODULES="button snd_hda_intel snd_usb_audio"
Comment 1 Phil Knirsch 2006-12-21 06:24:23 EST
Are you using a Xen kernel by any chance? If yes, please try it with a normal
kernel instead and see if you get the same problem.

Read ya, Phil
Comment 2 Carl Roth 2006-12-21 11:17:59 EST
Linux huggy 2.6.18-1.2868.fc6 #1 SMP Fri Dec 15 17:29:48 EST 2006 x86_64 x86_64
x86_64 GNU/Linux

This is a stock x86_64 kernel from Fedora updates.  I'm not using Xen.
Comment 3 Phil Knirsch 2006-12-21 11:22:03 EST
Ah, yea. 64bit kernels are also know to still have problems doing proper suspend
or hibernate in many cases.

Setting it to kernel as this is definitely a kernel problem though.

Read ya, Phil
Comment 4 Nigel Cunningham 2007-06-12 03:01:58 EDT
Are you still seeing this issue? If so, could you please attach dmesg from a
failed attempt? Could you also try a more recent kernel?
Comment 5 Carl Roth 2007-07-19 23:01:11 EDT
I still get this problem with 2.6.20-1.2962.fc6.  I'm attaching a recent dmesg file.

Note that I tried the following hack from


# echo $((400*1024*1024)) > /sys/power/image_size

and initial tests indicate that suspend/resume works with this.

As per the message, I don't understand it either.
Comment 6 Carl Roth 2007-07-19 23:21:49 EDT
Created attachment 159629 [details]
Kernel dmesg output
Comment 7 Nigel Cunningham 2007-12-10 17:26:17 EST
Is this better with newer kernels? I haven't checked, but Rafael has probably
merged that patch into vanilla if it helped (or made other fixes).
Comment 8 Bug Zapper 2008-04-04 01:18:53 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 9 Bug Zapper 2008-05-06 13:13:05 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.