Bug 220386 - Kernel Packages for profile sync behave incorrectly
Kernel Packages for profile sync behave incorrectly
Status: CLOSED DUPLICATE of bug 204345
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
high Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
:
Depends On:
Blocks: 173448 193563
  Show dependency treegraph
 
Reported: 2006-12-20 16:48 EST by Pradeep Kilambi
Modified: 2007-07-20 11:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 11:58:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel pkgs shown for sync incorrectly (227.83 KB, image/png)
2006-12-20 16:48 EST, Pradeep Kilambi
no flags Details
the resultant failed webui scheduled action (270.80 KB, image/png)
2006-12-20 17:02 EST, Pradeep Kilambi
no flags Details
Action it tried for kernel (248.93 KB, image/png)
2006-12-20 17:03 EST, Pradeep Kilambi
no flags Details

  None (edit)
Description Pradeep Kilambi 2006-12-20 16:48:55 EST
Description of problem:

rhn_check keep getting this error:

END: solve deps Wed Dec 20 21:05:39 2006
deps solved
New Up2date available
D: Sending back response (40, "Failed: The transaction failed for the following
reasons:\n[('package kernel-2.6.9-34.0.2.EL is already installed', (2, '',
0L))]", {'failed_elements': [('package kernel-2.6.9-34.0.2.EL is already
installed', (2, '', 0L))], 'version': '0', 'name':
'packages.runTransaction.failed_transaction'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: Called refresh_rpmlist
D: local action status:  (0, 'rpmlist refreshed', {})
[root@test08-64 ~]#

The reason is that the web side of code incorreclty allows the schedule of sync
between kernals even though the kernels are the same on both boxes and the diff
sent to client has only one of it set to install. 

as follows:
the scheduled actions queue sent to client looks like this D: do_call
packages.runTransaction ({'packages': [[['kernel', '2.6.9', '34.0.2.EL', '',
''], 'i']]....]

so only one of those kernel packages is scheduled for install and not for
removal and so it fails with package already installed as above.
Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. register two systems against webqa
2. goto software - > profile -> and click compare or compare against
system/store profiles.
3. see that kernel packages show up erraneously as in attachment and once
scheduled sends only one of those (i guess the kernel package that client is not
running in this case) in the delta to rhncheck.
4. run rhn_hceck and it should fail on kernel packages saying already installed.
  
Actual results:

The kernel packages are shown for sync profile even though they are already
available. see attachment and above error for more info

Expected results:

If the kernel package is already available(same as the client),it should not
show up in the profile sync list of packages. 

Additional Info:

As we can see the two boxes ahve the same kernels and it still shows it in the
webui diff

[root@test08-64 ~]# rpm -q --qf='%{n}-%{v}-%{r}-%{ARCH}\n' kernel
kernel-2.6.9-22.EL-x86_64
kernel-2.6.9-34.0.2.EL-x86_64

[root@test07-64 up2date_client]# rpm -q --qf='%{n}-%{v}-%{r}-%{ARCH}\n' kernel
kernel-2.6.9-22.EL-x86_64
kernel-2.6.9-34.0.2.EL-x86_64

this should not happen.
Comment 1 Pradeep Kilambi 2006-12-20 16:48:56 EST
Created attachment 144145 [details]
kernel pkgs shown for sync incorrectly
Comment 2 Pradeep Kilambi 2006-12-20 17:02:07 EST
Created attachment 144146 [details]
the resultant failed webui scheduled action

And the scheduled actiona fails as shown.
Comment 3 Pradeep Kilambi 2006-12-20 17:03:19 EST
Created attachment 144147 [details]
Action it tried for kernel

Action it trys and fails, as we can see out of so many deps all are solved
except the kernel.
Comment 4 Brandon Perkins 2007-07-20 11:58:27 EDT
Duplicate of Bugzilla Bug 204345.

*** This bug has been marked as a duplicate of 204345 ***

Note You need to log in before you can comment on or make changes to this bug.