Bug 22039 - at-3.1.8-12 requires /etc/init.d
at-3.1.8-12 requires /etc/init.d
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: at (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-10 16:35 EST by Moritz Barsnick
Modified: 2014-03-16 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-10 16:35:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2000-12-10 16:35:24 EST
For some reason, at-3.1.8-12 requires /etc/init.d:

root@sunshine:/usr/new/RedHat/7.x # rpm -Uvh at-3.1.8-12.i386.rpm
error: failed dependencies:
        /etc/init.d   is needed by at-3.1.8-12

Yet /etc/init.d has been (re-)abandoned for /etc/rc.d/init.d.
Comment 1 Bill Nottingham 2000-12-11 01:25:22 EST
/etc/init.d has not been re-abandoned. It just requires significant RPM
hoop-jumping to make the switch cleanly.

It requires it because the init script sources /etc/init.d/functions.
Comment 2 Moritz Barsnick 2000-12-11 04:09:12 EST
Sorry, I wasn't aware that I had to jump through the chkconfig hoop, where
./etc/init.d -> rc.d/init.d
is provided.  ;->

Note You need to log in before you can comment on or make changes to this bug.