Bug 220392 - rpm --import core dumps
rpm --import core dumps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
:
: 236302 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 17:14 EST by Nigel Horne
Modified: 2008-05-02 03:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 13:57:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2006-12-20 17:14:41 EST
Description of problem:

rpm --import will core dump if given an incorrect URL


Version-Release number of selected component (if applicable):
rpm-4.4.2-32

How reproducible:
100%


Steps to Reproduce:
1. rpm --import http://www.google.com
2.
3.
  
Actual results:
error: http://www.google.com: import read failed(-1).
Segmentation fault (core dumped)


Expected results:
error: http://www.google.com: import read failed(-1).


Additional info:
Comment 1 Jeff Johnson 2006-12-20 22:43:22 EST
Index: rpmdav.c
===============================================================
====
RCS file: /cvs/devel/rpm/rpmio/rpmdav.c,v
retrieving revision 2.19.2.15
diff -u -b -B -w -p -r2.19.2.15 rpmdav.c
--- rpmdav.c    24 Nov 2006 17:34:48 -0000      2.19.2.15
+++ rpmdav.c    21 Dec 2006 03:42:00 -0000
@@ -294,6 +294,7 @@ static int davConnect(urlinfo u)
 if (_dav_debug)
 fprintf(stderr, "*** Connect to %s:%d failed(%d):\n\t%s\n",
                   u->host, u->port, rc, ne_get_error(u->sess));
+       u = urlLink(u, __FUNCTION__);   /* XXX error exit refcount adjustment */
        break;
     }

Will be in rpm-4.4.8-0.6 when built.

UPSTREAM
Comment 2 Panu Matilainen 2007-07-03 07:29:57 EDT
Also fixed in rpm.org tree now. F7 and rawhide are not affected as they don't
use neon transport.
Comment 3 Red Hat Bugzilla 2007-08-21 01:30:22 EDT
User pnasrat@redhat.com's account has been closed
Comment 4 Panu Matilainen 2007-08-22 02:34:28 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 5 Panu Matilainen 2007-08-27 13:57:20 EDT
This has been fixed in rpm-4.4.2.1-1.fc6 which has now been pushed to updates.
Comment 6 Panu Matilainen 2008-05-02 03:26:03 EDT
*** Bug 236302 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.