Bug 220417 - Loading of SGI images is broken due to bad endian swap code
Loading of SGI images is broken due to bad endian swap code
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: DevIL (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-20 22:51 EST by Scott A. Friedman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 16:46:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix borked endian byteswapping (788 bytes, patch)
2006-12-20 22:51 EST, Scott A. Friedman
no flags Details | Diff

  None (edit)
Description Scott A. Friedman 2006-12-20 22:51:48 EST
Description of problem:
This used to work just fine - but someone broke it along the way by trying to be
clever. Anyway, attached patch uses internal linux byteswap functionality when
requested in place of broken 'asm' 

Version-Release number of selected component (if applicable):
1.6.8-0.10.rc2

How reproducible:
Try loading an SGI image file - you will get an INVALID HEADER error because the
header values are not converted from big endian to little endian (when required)

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Image file doesn't load

Expected results:
Image file should load!

Additional info:
I can attach an sgi rgb file for testing - but the patch I included works as
long as it is added to the spec file.
Comment 1 Scott A. Friedman 2006-12-20 22:51:48 EST
Created attachment 144159 [details]
patch to fix borked endian byteswapping
Comment 2 Ian Chapman 2007-01-02 16:46:07 EST
Thanks for patch. It's been added to the next version which should appear in the
repo shortly.

Note You need to log in before you can comment on or make changes to this bug.