Bug 220439 - kdesvn does not work with svn shipped with FC6
Summary: kdesvn does not work with svn shipped with FC6
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: esmtp (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
urgent
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-21 10:30 UTC by Liam Sharp
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 21:10:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Files lacking status information (105.53 KB, image/jpeg)
2006-12-21 10:46 UTC, Liam Sharp
no flags Details

Description Liam Sharp 2006-12-21 10:30:20 UTC
Using:

kdesvn --version
Qt: 3.3.7
KDE: 3.5.5-0.2.fc6 Fedora-Core
kdesvn: 0.11.0

and the svn shipped with FC6

svn --version
svn, version 1.4.2 (r22196)
   compiled Nov  9 2006, 09:17:49

esvn does not work. All the files have status "Not versioned", the other columns
in the GUI are not populated.

The logs from the terminal from which I launched kdesvn are: ( this line is
logged lots of times, probably for each subdir in my working directory).

.svn/entries:1:1:error occurred while parsing element

Having a dig around online, it seems the .svn/entries file format has changed
from XML to a text format; the error line above certainly points to this.

Having a dig around online I found the following that also suggest this, along
with a patche.

http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg263757.html

http://bugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=387447

Comment 1 Liam Sharp 2006-12-21 10:46:40 UTC
Created attachment 144175 [details]
Files lacking status information

Comment 2 Orion Poplawski 2006-12-22 21:10:28 UTC
It looks like you are using "esvn" not "kdesvn".  esvn does not appear to be in
FE or FC.  Perhaps you are using a different repository?

FWIW - kdesvn works fine for me.  Perhaps you should try it!


Note You need to log in before you can comment on or make changes to this bug.