Bug 220448 - Can't import GPG key into RPM database
Can't import GPG key into RPM database
Status: CLOSED DUPLICATE of bug 205080
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 07:57 EST by Felix Schwarz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 07:24:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2006-12-21 07:57:10 EST
I have a GPG key which seems to work without any problems (enigmail works,
command line too). I tried to sign rpm packages with that key. That works too.

The problem appears when a user tries to import my key with "rpm --import ..".
There is no error message but "rpm -q gpg-pubkey" does not show my key id. So
yum complains when I try  to install packages which are signed by my key.

I see the problem with Fedora Core 6 (x86_64, i386) and CentOS 4.4 (i386) but I
think, the problem is much older. The "problematic" key has the id 0x5dd76932
and can be found on the usual key servers. I can import other GPG keys without
problems.

Jeff Johnson reported
(http://www.redhat.com/archives/rpm-list/2006-December/msg00093.html) that this
is likely to be a Fedora bug as 4.4.8 can import my key.
Comment 1 Red Hat Bugzilla 2007-08-21 01:30:31 EDT
User pnasrat@redhat.com's account has been closed
Comment 2 Panu Matilainen 2007-08-22 02:31:37 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 3 Panu Matilainen 2007-10-25 07:24:05 EDT
Seems to be a dupe as the same fix(es) in JBJ's rpm 4.4.7/8 reportedly fix...

*** This bug has been marked as a duplicate of 205080 ***

Note You need to log in before you can comment on or make changes to this bug.