Bug 220468 - nvidia-glx.i broken and misclassified as daemon
nvidia-glx.i broken and misclassified as daemon
Product: Fedora
Classification: Fedora
Component: initng-ifiles (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Malmgren
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-12-21 10:50 EST by Jason Farrell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-22 03:15:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch against old (1.25 KB, patch)
2006-12-21 11:05 EST, Jason Farrell
no flags Details | Diff

  None (edit)
Description Jason Farrell 2006-12-21 10:50:54 EST
Description of problem:
nvidia-glx.i fails to start in FC6 for a variety of reasons.
1) because of a bash if/then syntax error
2) invalid "return $retval" which should be "exit ${retval}"
3) /dev/nvidia* devices missing

Also, this script should really be moved to system/nvidia-glx.i, since it only
updates /etc/X11/xorg.conf once when run.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install the official nvidia kmod from livna
2. ng-update add daemon/nvidia-glx
3. reboot
Actual results:
X won't start because of syntax errors in nvidia-glx.i and because of missing
/dev/nvidia* devices.

Expected results:
nvidia device files installed, and service starts.

Additional info:
Below is my working version for FC6:

# This is a i file, used by initng parsed by install_service

service daemon/nvidia-glx {
        need = system/bootmisc;
        env_file = /etc/sysconfig/nvidia-config-display;

        script start = {
                [ ! -f /dev/nvidiactl ] && cp -a /etc/udev/devices/nvidia* /dev
                echo "Checking for nvidia kernel module..."
                module="/lib/modules/`uname -r`/extra/nvidia/nvidia.ko"
                if [ -f $module ]; then
                        echo "Enabling nvidia-glx driver"
                        /usr/sbin/nvidia-config-display enable
                        echo "`basename ${module}` module for `uname -r` kernel
not found"
                        echo "Disabling nvidia-glx driver"
                        /usr/sbin/nvidia-config-display disable
                [ "$retval" == "0" ] && /bin/touch /var/lock/subsys/nvidia-glx
                exit ${retval}

        script stop = {
                /usr/sbin/nvidia-config-display disable
                [ "$retval" -eq "0" ] && /bin/rm -f /var/lock/subsys/nvidia-glx
                exit ${retval}
Comment 1 Jason Farrell 2006-12-21 11:05:02 EST
Created attachment 144193 [details]
patch against old
Comment 2 Daniel Malmgren 2006-12-22 03:15:42 EST
Thanks for your report. This script is now fixed in svn (thanks deac). The
copying of stuff from /etc/udev/devices isn't really needed anymore though,
since we've now added a proper copying (in svn) of entire /etc/udev/devices to
system/udev/filldev which is earlier in the boot order.

I don't think it's really clear why the script should be moved from daemon to
system. The difference between daemon and system practically makes no difference
other than estethical, and it's very unclear what belongs where...
Comment 3 Daniel Malmgren 2006-12-22 03:25:24 EST
Sorry. Guess this one shouldn't be closed as UPSTREAM but NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.