Bug 220472 - Printing to HP OfficeJet All In One printer fails
Printing to HP OfficeJet All In One printer fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-12-21 11:14 EST by P Jones
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.6.12-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 10:55:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Jones 2006-12-21 11:14:23 EST
Description of problem:

On an updated (as of 12/21/06) fc6, printing to a JetDirect connected HP
OfficeJet 7110 All In One printer will not work the first time I try to print.

Version-Release number of selected component (if applicable):

How reproducible:

Boot machine, login as regular user or root, open something to print, try to
print. This will not be successful, "open device failed; will retry in 30
seconds..." is the error shown in the CUPS web configuration. Waiting 30 seconds
or more does not change status. Canceling the job and attempting to print again
will be successful, or canceling the job, scanning something with XSane, and
trying to print again will be successful. In both circumstances, after the
printer has been "woken up", canceling the job from the printer works and
updates CUPS correctly. Restarting CUPS and HPLIP after the first print has
failed does not correct the problem.

I have tried this with firewall and SElinux off, the result is the same.

I have an HP LaserJet 5 that is also JetDirect connected and this printer prints
the first time with no problems.
Comment 1 Tim Waugh 2007-01-05 10:32:52 EST
What does 'lpstat -s' say?
Comment 2 P Jones 2007-01-05 12:43:28 EST
Hi Tim;

[pjones@pc-00105 ~]$ lpstat -s
system default destination: LaserJet-5
device for LaserJet-4000n: socket://192.168.0.100:9100
device for LaserJet-5: socket://192.168.1.111:9100
device for officejet_7100: hp:/net/officejet_7100_series?ip=192.168.1.110
device for officejet_7100_fax: hpfax:/net/officejet_7100_series?ip=192.168.1.110

-Pete
Comment 3 Tim Waugh 2007-01-11 08:41:35 EST
Please try 1.6.12 from updates-testing:

yum --enablerepo=updates-testing update 'hplip*' 'hpijs*' 'libsane-hpaio*'
Comment 4 P Jones 2007-01-11 10:22:11 EST
Tim;

OK, installed udates, powered off the machine and then powered it on. Now when
trying to scan I first get the "Failed to open device
'hpaio:/net/officejet_7100_series?ip=192.168.1.110': Error during device I/O." I
click OK and try again, then I get the Xsane interface. Scanning then works
correctly.

Power off machine, then power on. Open gedit, type a word, then attempt to print
to Officejet. Printer is not in power saving mode, I get the printer applet, it
shows document status as printing. Wait for five minutes, the document does not
print, no activity at the printer. Do an lpstat -s, I get the same results as above.

So then I open a browser and go to localhost:631, cancel the job. Printer
applet, which is still open, pops up a message telling me the job has been
canceled and I may want to find out why. Immediately attempt to print the same
gedit document and it works. Immediately attempt to scan and it works without
errors.

Let me know what else you'd like me to try.
Comment 5 Tim Waugh 2007-01-11 12:35:13 EST
What does this say?:

grep -Ew '(hpssd|hpiod)' /var/log/messages
Comment 6 P Jones 2007-01-11 13:01:33 EST
Tim;

After a power on;

Jan  7 11:01:20 pc-00183 hpiod: device cleanup
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan  7 11:01:20 pc-00183 hpiod: device active clientcnt=1 channelcnt=0
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan  7 11:54:40 pc-00183 python: hpssd[2325]: warning: Inrecognized URI:
socket://192.168.1.111:9100
Jan  7 13:19:28 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan  8 12:47:27 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan  8 15:17:43 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan  8 15:36:39 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan  8 18:37:19 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan  9 06:49:36 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan  9 08:00:59 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan  9 14:58:53 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan 10 06:51:56 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan 10 15:00:38 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan 11 08:02:23 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan 11 09:17:25 pc-00183 hpiod: device cleanup
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan 11 09:19:43 pc-00183 hpiod: 1.6.10 accepting connections at 2208... 
Jan 11 09:27:06 pc-00183 hpiod: device cleanup
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan 11 09:28:56 pc-00183 hpiod: 1.6.12 accepting connections at 2208... 
Jan 11 09:33:48 pc-00183 hpiod: timeout JetDirectChannel::ReadData: Invalid
argument hp:/net/officejet_7100_series?ip=192.168.1.110 io/hpiod/jetdirect.cpp 325 
Jan 11 09:36:05 pc-00183 hpiod: device cleanup
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan 11 09:36:05 pc-00183 hpiod: device active clientcnt=1 channelcnt=0
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan 11 09:50:15 pc-00183 hpiod: 1.6.12 accepting connections at 2208... 
Jan 11 10:03:28 pc-00183 hpiod: device cleanup
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan 11 10:08:13 pc-00183 hpiod: 1.6.12 accepting connections at 2208... 
Jan 11 10:14:18 pc-00183 hpiod: device cleanup
uri=hp:/net/officejet_7100_series?ip=192.168.1.110 
Jan 11 12:49:54 pc-00183 hpiod: 1.6.12 accepting connections at 2208... 
Comment 7 Tim Waugh 2007-01-15 12:24:11 EST
Jan 11 09:33:48 pc-00183 hpiod: timeout JetDirectChannel::ReadData: Invalid
argument hp:/net/officejet_7100_series?ip=192.168.1.110 io/hpiod/jetdirect.cpp 325

The 'invalid argument' bit there is a red herring, I think.  The problem was a
time-out (longer than 45s).
Comment 8 P Jones 2007-03-06 10:55:11 EST
Well, I can't exlain why but this bug seems to be resolved on my network now.

[pjones@localhost ~]$ rpm -qa hpijs hplip libsane-hpaio
libsane-hpaio-1.6.12-1.fc6
hpijs-1.6.12-1.fc6
hplip-1.6.12-1.fc6

Note You need to log in before you can comment on or make changes to this bug.