Bug 220535 - An LVM swap filesystem no longer mounts - kernel-2.6.19-1.2889.fc7
An LVM swap filesystem no longer mounts - kernel-2.6.19-1.2889.fc7
Status: CLOSED DUPLICATE of bug 241288
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
https://www.redhat.com/archives/fedor...
:
Depends On: 241288
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-21 17:35 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 17:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Messages from day before problem, day of problem and day after (478.68 KB, text/plain)
2006-12-21 17:35 EST, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2006-12-21 17:35:09 EST
Description of problem:
After finally being able to boot an fc7 kernel where the devices are referred to
as sdx instead of hdx, I no longer have my swap that is usually mounted.
Below is the mount detected using kernel-2.6.18-1.2849.fc6.

Adding 500464k swap on /dev/hdb3.  Priority:-1 extents:1 across:500464k
Adding 524280k swap on /dev/hda5vol/LogVol01.  Priority:-2 extents:1 across:524280k

I guess attaching /var/log/messages would reveal the errors encountered better.
Basically swap does not work on my LVM. Swap on a /dev/sdb3 does however work.

Version-Release number of selected component (if applicable):
Working kernel - kernel-2.6.18-1.2849.fc6
No LVM swap kernel - kernel-2.6.19-1.2889.fc7


How reproducible:
Get the working mkinitrd installed, mkinitrd-6.0.6-1 and then yum update the
kernel onto the system. Reboot into the new kernel

Steps to Reproduce:
1. boot computer
2. see various errors pass by relating to the filesystem on /dev/sda
3. detect no swap.
  
Actual results:
With kernel-2.6.18-1.2849.fc6 
swapon -s
Filename                                Type            Size    Used    Priority
/dev/hdb3                               partition       500464  76      -1
/dev/mapper/hda5vol-LogVol01            partition       524280  0       -2

with kernel-2.6.19-1.2889.fc7, no /dev/mapper/hda5vol-LogVol01 detected

Expected results:
For the LVM to mount

Additional info:
I really do not need the LVM swap partition but being that it was used
previously, I figure that it is a bug.
Comment 1 Jim Cornette 2006-12-21 17:35:10 EST
Created attachment 144229 [details]
Messages from day before problem, day of problem and day after
Comment 2 Jim Cornette 2006-12-21 18:23:51 EST
Just a few keys to know what is relevent. I installed all the packages and the
kernel would not boot. I erased the kernel.
Dec 20 19:21:10 cornette-dell-hdb Erased: kernel
Afterwards, I rebooted the system. The errors previous to that time are pretty
much pre-successful installation of the kernel.
Comment 3 Jim Cornette 2006-12-21 18:29:30 EST
Shutting down while using fc7 kernel
Dec 21 07:01:13 cornette-dell-hdb exiting on signal 15

Running the fc6 kernel:
Dec 21 17:04:46 cornette-dell-hdb syslogd 1.4.1: restart.
Comment 4 Jim Cornette 2006-12-21 19:12:35 EST
THe new kernel still errors as the previous version.
swapon -s
Filename                                Type            Size    Used    Priority
/dev/sdb3                               partition       500464  0       -1
[root@cornette-dell-hdb ~]# uname -r
2.6.19-1.2890.fc7
Comment 5 Jim Cornette 2007-01-21 13:53:55 EST
I still am not able to use the swap in the lvm. It does not mount. The lvm
information is below.
 --- Logical volume ---
  LV Name                /dev/hda5vol/LogVol01
  VG Name                hda5vol
  LV UUID                vEHuGt-69GE-kVw8-1NJW-DoPv-SEXQ-hjXQth
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                544.00 MB
  Current LE             17
  Segments               1
  Allocation             inherit
  Read ahead sectors     0
  Block device           253:1

 swapon -v /dev/hda5vol/LogVol01
swapon on /dev/hda5vol/LogVol01
[root@cornette-dell-hdb ~]# swapon -s
Filename                                Type            Size    Used    Priority
/dev/sdb3                               partition       500464  6452    -1
Comment 6 Jim Cornette 2007-01-31 17:56:39 EST
The LVM SWAP still does not work. Keeping bug as active. No new information.
Comment 7 Jim Cornette 2007-06-04 17:41:53 EDT
The error is caused by bug 241288

*** This bug has been marked as a duplicate of 241288 ***

Note You need to log in before you can comment on or make changes to this bug.