Bug 220581 - disconnecting and connecting a network interface does not refresh DNS records
disconnecting and connecting a network interface does not refresh DNS records
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-22 02:47 EST by Nadav Kavalerchik
Modified: 2009-07-14 12:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadav Kavalerchik 2006-12-22 02:47:39 EST
Description of problem:
i open the system-config-network app

i disconnect interface eth0 and connect to it again.
(the interface is set to automatic DNS retrival)
and it doesn't refreash the dns info.

it only works after quiting the system-config-network app
and reopening it again.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
DNS records are not refreshed

Expected results:
it should reflect the DNS refreshed IPs without the need to quit the app and
reopen it.


Additional info:
Comment 1 Juan Manuel Borges Caño 2007-01-20 10:43:13 EST
same problem, same behaviour
temporarily i put a command that creates the correct /etc/resolv.conf in
/etc/NetworkManager/dispatcher.d/resolv.sh (read man pages)
Comment 2 Juan Manuel Borges Caño 2007-11-09 17:15:20 EST
I'm thinking that it doesn't have the expected behaviour for a configuration
application, so I tried to set severity to high, I can't as I'm not the owner of
the bug neither a developer of the application.

Correct me if I'm wrong, please.
Comment 3 Harald Hoyer 2007-11-12 02:57:25 EST
s-c-network or NetworkManager??
Comment 4 Nadav Kavalerchik 2007-11-12 03:45:28 EST
s-c-network (on fc6) maybe on fc8 it does (i didn't check) :-)
Comment 5 Harald Hoyer 2007-11-12 06:02:38 EST
Expected results:
it should reflect the DNS refreshed IPs without the need to quit the app and
reopen it.

Ah, you mean, rereading /etc/resolv.conf inside of s-c-network ?
Comment 6 Juan Manuel Borges Caño 2007-11-12 08:42:24 EST
 Ok, I think that I'm talking about a different bug.
 When I was setting the dns from system-config-network in fc6 it asked me to
save, then /etc/resolv.conf was updated, but when I restarted the computer the
/etc/resolv.conf was empty.
 Should I report it as a different bug?
 Should I test it in f8? i.e. there was some code modifications to fix it ?
Comment 7 Harald Hoyer 2007-11-12 10:08:24 EST
reassigning to dhcp
Comment 8 David Cantrell 2008-02-05 23:28:29 EST
I am able to disconnect and reconnect my wired ethernet connection. 
NetworkManager is in charge on my system and when it runs dhclient on the newly
active wired interface, a new resolv.conf file is written in the /etc directory.

If I take NetworkManager out of the equation and just run dhclient by hand, I
can use ifup and ifdown to restart the interface manually when I connect and
disconnect the wire, every time I get a new resolv.conf file.
Comment 9 Nadav Kavalerchik 2008-02-06 02:49:17 EST
this bug has nothing to do with NetworkManager
please see that WHILE i am using the system-config-network the
information inside its interface does not change to reflect the 
actual network status of the machine.

maybe you can add a "Refresh" button ? or hock to the hal/dbus
to refresh the interface when any thing related to the NICs changes.
or just notification ?

(i'm using fc6, maybe it's solved in fc8/rawhide ?
please someone check)
Comment 10 Harald Hoyer 2008-02-06 07:07:56 EST
IIRC, there was a problem with dhclient writing /etc/resolv.conf
If you do not want dhclient (dhcp) to update/write to /etc/resolv.conf, you
should add to your /etc/sysconfig/network-scripts/ifcfg-eth0 config file:
PEERDNS=no
Comment 11 Nadav Kavalerchik 2008-02-06 07:38:12 EST
Harld: i do want it to be changed.

i think system-config-network should monitor /etc/resolv.conf
or the dhcpclient and change the content of the interface's DNS fields
dynamically when it changes
Comment 12 Harald Hoyer 2008-02-06 07:49:49 EST
ah, yes, sure.. sry.. was confused by the other comments :)
Comment 13 David Cantrell 2008-02-06 12:36:07 EST
Harald,

It seems this is a s-c-network bug and not a dhcp bug at this point.
Comment 14 Bug Zapper 2008-05-13 22:31:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Ragavendra 2008-05-23 14:39:55 EDT
Similar isuue.
I have F9. During install I gave my old DNS setting for primary and secondary
Primary DNS server	61.1.96.69

Secondary DNS server	61.1.96.71
since I don't remember the latest DNS settings.

Now, since I have the current DNS settings with me which is 
Primary DNS server	218.248.240.23
Secondary DNS server	218.248.240.135
I am unable to save it in System->Administration->Network----DNS

I tried it a numerous of times but no luck.
Comment 16 Ragavendra 2008-05-23 17:38:43 EDT
I manually did this to nake the latest DNS's permanent. It worked

NetworkManager on Fixed Networks

On machines with a fixed networking device and a fixed IP address (e.g. desktop,
server, appliance), it might be easier to disable NetworkManager and use the
older network service. Note that the Fedora 9 installer disables the network
service by default. To switch to using the network service:

First disable NetworkManager and prevent it from automatically loading:

[ragavendra_bn@linuxflavour.co.in ~]$ sudo /etc/init.d/NetworkManager stop
Stopping NetworkManager daemon: [ OK ]

[ragavendra_bn@linuxflavour.co.in ~]$ sudo /sbin/chkconfig --level 35
NetworkManager off

Next, configure your network settings:

[ragavendra_bn@linuxflavour.co.in ~]$ sudo system-config-network

You should have an eth0 device already showing. To configure the IP settings
click on Edit. Do not forget to set DNS on the DNS tab (if you're using fixed
IP's). Make sure the eth0 is selected as Active. Then File > Save and quit.

Next, enable the service and make sure it loads at next boot:

[ragavendra_bn@linuxflavour.co.in ~]$ sudo /etc/init.d/network start
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: [ OK ]

[ragavendra_bn@linuxflavour.co.in ~]$ sudo /sbin/chkconfig --level 35 network on

While it may be possible to re-activate your network without a reboot, it may be
recommended to reboot.


Now no need to edit my DNS again & again. Although manually resolved but still
is a bug maybe:).
Comment 17 Bug Zapper 2009-06-09 18:23:17 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Bug Zapper 2009-07-14 12:58:28 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.