Bug 220588 - gcc crashes while compiling UML kernel
gcc crashes while compiling UML kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-22 05:33 EST by Yan Burman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.1-31
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 06:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The preprocessed source that generated the error (1.02 MB, text/plain)
2006-12-22 05:36 EST, Yan Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 29241 None None None Never

  None (edit)
Description Yan Burman 2006-12-22 05:33:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061108 Fedora/1.5.0.8-1.fc5 Firefox/1.5.0.8

Description of problem:
I was compiling linux kernel 2.6.20-rc1 for UML, and since the UML was not working, I changed the CFLAGS to be -g3 -O0.

Version-Release number of selected component (if applicable):
gcc-4.1.1-1

How reproducible:
Always


Steps to Reproduce:
1. Change CFLAGS in kernel Makefile to include -g3 -O0
2. Compile kernel 2.6.20-rc1 with ARCH=um
3. Removed some inline from some functions to make it compile - too much info to specify in this short form

Actual Results:
net/ipv4/ip_output.c: In function ‘ip_output’:
net/ipv4/ip_output.c:208: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccO5Lw9n.out file, please attach this to your bugreport.

Expected Results:
The file should have been compiled

Additional info:
Comment 1 Yan Burman 2006-12-22 05:36:21 EST
Created attachment 144266 [details]
The preprocessed source that generated the error
Comment 2 Jakub Jelinek 2006-12-22 06:25:24 EST
Fixed in gcc-4.1.1-31 and above (e.g. FC6 testing updates now has 4.1.1-47.fc6).
FC5 updates will have the same codebase when they are prepared.

Note You need to log in before you can comment on or make changes to this bug.