Bug 220600 - hddtemp.i - needs to be run as daemon
hddtemp.i - needs to be run as daemon
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initng-ifiles (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Malmgren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-22 09:04 EST by Jason Farrell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-30 02:13:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2006-12-22 09:04:11 EST
Description of problem:
hddtemp.i needs to run hddtemp with the "-d" flag.

Version-Release number of selected component (if applicable):
initng-ifiles-0.0.6-2.fc6

How reproducible:
always

Steps to Reproduce:
1. ng-update add hddtemp 
2. boot
3. nc localhost 7634

Actual results:
no results, because hddtemp only ran once.

Expected results:
|/dev/sda|HDS722525VLSA80|35|C||/dev/sdb|HDS722525VLSA80|33|C||/dev/sdc|HDS722525VLSA80|33|C||/dev/sdd|HDS722525VLSA80|34|C|

Additional info:
Also note that hddtemp on redhat creates /etc/sysconfig/hddtemp for sysv init's
use. mine contains:
HDDTEMP_OPTIONS="-l 127.0.0.1 /dev/sda /dev/sdb /dev/sdc /dev/sdd"

As hddtemp.i is currently written, all that's needed to get it working is for
the following (missing) RUN_DAEMON env to be added:

--- hddtemp.i.orig      2006-12-22 06:43:23.000000000 -0500
+++ hddtemp.i   2006-12-22 06:51:18.000000000 -0500
@@ -11,6 +11,7 @@
        env PORT=7634;
        env SEPARATOR=|;
        env SYSLOG=0;
+       env RUN_DAEMON=yes;
        env_file = /etc/conf.d/hddtemp;
        script daemon = {
                [ -n "${SYSLOG}" -a "${SYSLOG}" != "0" ] && SYSLOG_ARG="-S
${SYSLOG}"
Comment 1 Daniel Malmgren 2006-12-30 02:12:35 EST
Hmmm... Since I don't use hddtemp myself I can't really confirm this, but I've
commited it into upstreams svn. About the writing of /etc/sysconfig/hddtemp I
guess a proper fix would be welcome...

Note You need to log in before you can comment on or make changes to this bug.