Bug 220623 - python-kid-0.9.4-1.fc6 break repoview
python-kid-0.9.4-1.fc6 break repoview
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: python-kid (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-12-22 11:36 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 13:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-12-22 11:36:45 EST
Description of problem:

repoview now crashes with:

Traceback (most recent call last):
  File "/usr/bin/repoview", line 854, in ?
    main()
  File "/usr/bin/repoview", line 851, in main
    rv.applyTemplates(opts.templatedir, title=opts.title, url=opts.url)
  File "/usr/bin/repoview", line 707, in applyTemplates
    outstr = kobj.serialize()
  File "/usr/lib/python2.4/site-packages/kid/__init__.py", line 283, in serialize
    return serializer.serialize(self, encoding, fragment, format)
  File "/usr/lib/python2.4/site-packages/kid/serialization.py", line 109, in
serialize
    text = ''.join(tuple(
  File "/usr/lib/python2.4/site-packages/kid/serialization.py", line 345, in
generate
    for ev, item in self.apply_filters(stream, format):
  File "/usr/lib/python2.4/site-packages/kid/serialization.py", line 165, in
format_stream
    for ev, item in stream:
  File "/usr/lib/python2.4/site-packages/kid/parser.py", line 218, in _coalesce
    for ev, item in stream:
  File "/usr/lib/python2.4/site-packages/kid/parser.py", line 174, in _track
    for p in stream:
  File "/usr/lib/python2.4/site-packages/kid/filter.py", line 22, in apply_matches
    for ev, item in stream:
  File "/usr/lib/python2.4/site-packages/kid/parser.py", line 174, in _track
    for p in stream:
  File "/usr/lib/python2.4/site-packages/kid/parser.py", line 218, in _coalesce
    for ev, item in stream:
  File "/usr/share/repoview/templates/group.py", line 41, in _pull
TypeError: generate_content() takes exactly 1 argument (2 given)


Version-Release number of selected component (if applicable):
python-kid-0.9.4-1.fc6

How reproducible:
every time
Comment 1 Konstantin Ryabitsev 2006-12-22 11:44:08 EST
Well, crap.
Comment 2 Konstantin Ryabitsev 2007-01-02 13:02:21 EST
This is actually not a bug in repoview, but in kid. Apparently, it generates
cached .pyc versions of templates and writes them out. Unfortunately, kid
doesn't currently check if pre-existing cached templates are still compatible
between versions, so it just blindly runs them. Since templates between 0.9.3
and 0.9.4 are not compatible, this generates an error.

This will be fixed in kid-0.9.5, see:
http://www.kid-templating.org/trac/ticket/189

I may backport this into 0.9.4 with a few other patches, unless 0.9.5 is out today.

Solution for you:
rm /usr/share/repoview/templates/*.py*

Note You need to log in before you can comment on or make changes to this bug.