Bug 220655 - release notes does not mention 3rd party video drivers
Summary: release notes does not mention 3rd party video drivers
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes   
(Show other bugs)
Version: devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Release Notes Tracker
QA Contact: Karsten Wade
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-22 19:48 UTC by Brian McMinn
Modified: 2007-04-18 17:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:06:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian McMinn 2006-12-22 19:48:46 UTC
Description of problem:

I just put together a new motherboard, a new 1440x900 monitor, and a 
new FC6 install.  I try to stay away from proprietary drivers because
they've caused me nothing but problems in the past.  I expected to have
trouble with my 1440x900 monitor and I did (but that's a different
issue).  The problem is that the release notes don't say anything about
proprietary video drivers.  However, even a casual web search for
how to fix up a 1440x900 display under Linux will result in plenty of
web pages that discuss various proprietary drivers.  So now the new
Linux user is puzzled - if this driver is necessary, how to get it?
Which copy to trust?  Why wasn't it on the install media?  Why won't
yum just fetch it?

I think the Release Notes owes the new user at least a short mention
of proprietary video drivers and probably a pointer off to some place
that describes them in more detail.  Otherwise, the casual user will
simply follow one or more of the sets of directions from the web,
download a driver and go on, potentially screwing up some other part
of his/her install (like libGL).

At fedoraproject.org, Mike Harris spells out a lot of the pitfalls that
come with these drivers so it's clearly a widespread problem.

Version-Release number of selected component (if applicable):


How reproducible:

Read release notes...

Steps to Reproduce:
1. Find Linux newbie
2. Install FC6 on odd hardware
3. Stand back and watch
  
Actual results:

Screwed up libGL

Expected results:

I'd rather use free drivers but that doesn't look likely any time soon.
Second choice would be to have a known good site to get these drivers
from and a pointer in the release notes that tells me about it and why
it is better than some random site.

Additional info:

Comment 1 Rahul Sundaram 2006-12-22 20:06:10 UTC

Release notes are for release specific information. Not general help. We did
provide a link to the note on 3rd party drivers from our release notes in FC5.
Seems that got missed out for FC6. I have added them back to
http://fedoraproject.org/wiki/Docs/Beats/Xorg

However note that Fedora is a completely Free software system and we dont want
to encourage the use of proprietary drivers not to mention potential legal
issues with liability and non-gpl compatible drivers. 

Please do open a separate bug report against Xorg with detailed information on
the monitor resolution issue. In many cases, we can fix the drivers or the
hardware detection process to do the right thing by default. Thank you. 


Note You need to log in before you can comment on or make changes to this bug.