Bug 220697 - hp-sendfax: cannot add items to the fax job list
hp-sendfax: cannot add items to the fax job list
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-23 08:49 EST by Vlado Potisk
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-23 11:46:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2006-12-23 08:49:05 EST
Description of problem:
I have installed new network multifunction device (HP LaserJet 3390). Printing
and scanning are OK, but faxing doesn't work. 

Version-Release number of selected component (if applicable):
hplip-1.6.10-1.fc6.4

How reproducible:
Always

Steps to Reproduce:
1.start hp-sendfax
2a.print to the printer fax queue
 or
2b.add a file to the list using hp-sendfax GUI

Actual results:
- Nothing happens with the hp-sendfax job list, it stays empty
- /var/log/messages says: python: [XXX] error: Unable to set locale. 
- For the print to queue method:
  CUPS lists the job as completed and the
  last line of /var/log/cups/error_log is:
  Started backend /usr/lib/cups/backend/hpfax (PID XXX) for job YYY
  (XXX is the same PID as in the python error message above)
- For the add file method:
  After clicking 'Add to list' a 'processing fax message' window with a
  progressbar moving back and forth appears and stays there unchanged
  until the window is closed.

Expected results:

The job should appear in the hp-sendfax list of fax jobs or in the case of an
error a reasonable diagnostics message should be displayed/logged.
Comment 1 Vlado Potisk 2006-12-23 11:46:04 EST
Please see here: http://hplip.sourceforge.net/howtos/known.html

Faxing works from the command line (verified) and the interaction with PyQt is
the cause of the problem. This has been already reported as PyQt bug #213508. If
hp-sendfax is fine then this bug is a dup.

Note You need to log in before you can comment on or make changes to this bug.