Bug 220706 - Review Request: linuxwacom-0.7.6_3-3.1.i386.rpm - with wacomcpl tool, man page
Review Request: linuxwacom-0.7.6_3-3.1.i386.rpm - with wacomcpl tool, man page
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Package Reviews List
:
: 220707 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-23 14:26 EST by Marcel Edward Verhagen
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-28 11:15:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild errors (23.92 KB, text/plain)
2007-02-05 16:00 EST, Dawid Zamirski
no flags Details
xorg crash (13.28 KB, text/plain)
2007-02-12 18:47 EST, Dawid Zamirski
no flags Details
My xorg.conf for reference (2.60 KB, application/octet-stream)
2007-02-13 00:23 EST, Marcel Edward Verhagen
no flags Details
rpmbuild output as user (30.91 KB, text/plain)
2007-02-15 10:43 EST, Dawid Zamirski
no flags Details
rpmbuild as root (30.58 KB, text/plain)
2007-02-15 10:43 EST, Dawid Zamirski
no flags Details

  None (edit)
Description Marcel Edward Verhagen 2006-12-23 14:26:54 EST
Spec URL: http://meverhagen.nl/fc6/linuxwacom.spec
SRPM URL: http://meverhagen.nl/fc6/linuxwacom-devel-0.7.6_3-3.1.i386.rpm
Debug URL: http://meverhagen.nl/fc6/linuxwacom-debuginfo-0.7.6_3-3.1.i386.rpm
RPM URL: http://meverhagen.nl/fc6/linuxwacom-0.7.6_3-3.1.i386.rpm
Description:
This is my first rpm,
it is lunixwacom 0.7.6 wich updates lunixwacom 0.7.4 
It includes the wacomcpl (wacomcpl-exec) tool, wich is used for adjusting the pressure of the stylus and the buttons on the drawing tablet.
And a manpage for the xorg.conf editing: man wacom
Comment 1 Peter Gordon 2006-12-23 14:43:19 EST
*** Bug 220707 has been marked as a duplicate of this bug. ***
Comment 2 Peter Gordon 2006-12-23 14:45:34 EST
Maybe it's just me, but I get a spinning globe GIF image for each of those URLs
with text "orbiting" it. Hotlink protection of some sort, perhaps? Though
refreshing the page (hence having my Referrer header that of your domain) does
not fix it.
Comment 4 Marcel Edward Verhagen 2007-01-05 00:17:57 EST
This is the second attempt to create a linuxwacom rpm wich updates linuxwacom !

Linuxwacom has updated to 0.7.6_4

the rpms can be found at http://meverhagen.nl/fc6/i386

spec url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6-4.spec
srpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.3.src.rpm
debug url: http://meverhagen.nl/fc6/i386/linuxwacom-debuginfo-0.7.6_4-3.3.i386.rpm
rpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.3.i386.rpm

The wacom rules has to be 49.wacom.rules since /dev/input/wacom has to be
created in order to make the wacomcpl tool to work

The xorg.conf file isn't updated throug the rpm I can use some help in how to
archieve this. So until know the xorg.conf still has to be manipulated manually. 
For the graphire 4 there should be 4 'Section "inputdevice"' added, and the
Section "ServerLayout" , Section "Module" get some new lines.
Comment 5 Didier 2007-02-05 05:13:06 EST
Testing 0.7.6_4-3.3 :

$ wacomcpl
shell-init: error retrieving current directory: getcwd: cannot access parent
directories: No such file or directory
wacomcpl: using TCLLIBPATH="[list  /usr/local/lib ]"
/usr/bin/wacomcpl: line 20: /usr/local/bin/wacomcpl-exec: No such file or directory


--> Looks like you'll need to patch /usr/bin/wacomcpl, stripping out "/local/".
Comment 6 Marcel Edward Verhagen 2007-02-05 08:33:25 EST
I have stripped out "/local/" and changed the configure part in the spec file.

the new rpm's:

spec url: http://meverhagen.nl/fc6/i386/linuxwacom-7.6.4-5.spec
srpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.6.src.rpm
debug url: http://meverhagen.nl/fc6/i386/linuxwacom-debuginfo-0.7.6_4-3.6.i386.rpm
rpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.6.i386.rpm

Comment 7 Didier 2007-02-05 10:10:17 EST
Tested with linuxwacom-0.7.6_4-3.6 :

$ wacomcpl
wacomcpl: using TCLLIBPATH="[list  /usr/lib ]"
Error in startup script: can't find package LIBWACOMXI
    while executing
"package require LIBWACOMXI"
    (file "/usr/bin/wacomcpl-exec" line 28)


Stracing wacomcpl seems to indicate it's looking for "[list/" and
"[list/pkgIndex.tcl".

Comment 8 Dawid Zamirski 2007-02-05 16:00:29 EST
Created attachment 147403 [details]
rpmbuild errors

Attached is the rpmbuild --rebuild output with errors that I got when doing so
as a non-root user.
Comment 9 Marcel Edward Verhagen 2007-02-05 19:26:07 EST
It is hard to create a good spec file ...

the new rpm's with the TkxXinput libs included:

spec url: http://meverhagen.nl/fc6/i386/linuxwacom-7.6.4-5.spec
srpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.7.src.rpm
debug url: http://meverhagen.nl/fc6/i386/linuxwacom-debuginfo-0.7.6_4-3.7.i386.rpm
rpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.7.i386.rpm

Comment 10 Marcel Edward Verhagen 2007-02-05 19:30:23 EST
(In reply to comment #8)
> Created an attachment (id=147403) [edit]
> rpmbuild errors
> 
> Attached is the rpmbuild --rebuild output with errors that I got when doing so
> as a non-root user.

I can't rebuild the package as non-root user. 
Should this be possible ?

The build fails cause you cannot delete the man page a non-root user, and you
haven't got the kernel-devel package installed.
Comment 11 Didier 2007-02-06 04:43:28 EST
Tested with linuxwacom-0.7.6_4-3.7 :
Exactly the same error as reported in comment #7.

wacomcpl is still looking for a file or directory "[list" and/or
"[list/pkgIndex.tcl", which does not exist.


Marcel : maybe you could install your RPM on a clean machine (with no traces of
linuxwacom builds), and strace wacomcpl to examine what exactly is missing ...

I am not acquainted with Tcl/Tk, but I'd guess the TkxXinput libs need to be
registered in a post-install spec scriptlet ?

TIA for your efforts.
Comment 12 Marcel Edward Verhagen 2007-02-06 23:00:16 EST
Another attempt:
It should work now.

spec url: http://meverhagen.nl/fc6/i386/linuxwacom-7.6.4-5.spec
srpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.8.src.rpm
debug url: http://meverhagen.nl/fc6/i386/linuxwacom-debuginfo-0.7.6_4-3.8.i386.rpm
rpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.8.i386.rpm

It's a good idea to test new RPM's on a clean machine, but I have only got one
pc. For now I have done a make uninstall in the BUILD dir. and installed the rpm.

ps. But I will study the making of the spec file when I have the time for it. 
The macro's used by makerpm somehow mess things up. And there are some other
vage things. 
Comment 13 Dawid Zamirski 2007-02-12 18:47:54 EST
Created attachment 147943 [details]
xorg crash

I have rebuilt and installed the src.rpm package as root today and X server
doesn't start. I also installed kernel-devel and rebuilt it as root (rebuild as
user doesn't work due to permissions as in my earlier comment). What's weird,
is that when I removed kernel-devel and choose the older version (I belive it
was linuxwacom-0.7.6_4-3.6.src.rpm) which was working well a few weeks ago, the
X server still crashes although the same steps worked for me before. I think
that it might be due to some of the Fedora updates that came out in the
meantime and broke the wacom module but I'm out of ideas what's wrong :-/
Comment 14 Marcel Edward Verhagen 2007-02-13 00:05:28 EST
The kernel-devel is just needed for reference.  

The xorg.conf is tricky. But from the log you it include it seems you have
include the wacom and stylus and so. This should be good. To be 100% sure this
crash isn't caused by the xorg.conf comment # the lines in the section
"ServerLayout" and the load "wacom" in the section "Module". However the wacom
module should fail to load if something is wrong, it should not crash the X server.

Hmmzzz you are trying to rebuild it for 64 bit. 
This could be a spec issue.
Try to download and compile the source from
http://linuxwacom.sourceforge.net/index.php/dl

use the following configure:

./configure --prefix=/usr --with-xorg-sdk=/usr --with-tcl=/usr --with-tk=/usr
--enable-xserver64

and then make and make install.
! remember ! if you want to uninstall this run: make uninstall

If the X server runs after compiling an installing it yourself, then it's
definitely a spec bug.

And if your X server still crashes then you should try to make a new xorg.conf
file. Rename it to xorg.backup and run system-config-display, this should give
you a new xorg.conf file without the wacom stuff.
 
I hope this will work
Comment 15 Marcel Edward Verhagen 2007-02-13 00:23:29 EST
Created attachment 147956 [details]
My xorg.conf for reference

Take special notice to the position of load "wacom" (it's at the top), the
mouse0 section and the various Section "InputDevice" (the PressCurve should be
in for pressure support, and the device should point to an existing
/dev/input/wacom (a symlink to event3))
Comment 16 Marcel Edward Verhagen 2007-02-13 03:36:03 EST
I cleanup up the spec file by removing the configure and makeinstall macro's.
The ./configure and make install should do, but I am not sure about the various
dirs on 64 bit the, %{_x11dir}/%{_lib} should reveal the x11 dir on 64 bit this
is /usr/lib64/. 
The rpm's are the same.
I hope the spec file is now working as it should work.

spec url: http://meverhagen.nl/fc6/i386/linuxwacom-7.6.spec
srpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.9.src.rpm
debug url: http://meverhagen.nl/fc6/i386/linuxwacom-debuginfo-0.7.6_4-3.9.i386.rpm
rpm url: http://meverhagen.nl/fc6/i386/linuxwacom-0.7.6_4-3.9.i386.rpm

Comment 17 Dawid Zamirski 2007-02-15 10:41:49 EST
Hi again :)

I have updated my xorg.conf with our settings and I'm still getting that libc
error when wacom gets loaded. Orginally I didn't have Modules section in my
xorg.conf but regardless of whether I add it or not it still gives the error.
Unfortunetely, I didn't get a chance to test it with building straight from the
upstream source and I'll do it as soon as I get back hom form work :) Also I
couldn't reuild the new src.rpom that you posted because it hives rpath errors
whe doung it as a user or other errors when rebuildign as root. I'll attach the
rebuild log for both cases.
Over the weekend I'll have more time and I will provide more constructive
feedback and hopefully we'll get it working :)
Comment 18 Dawid Zamirski 2007-02-15 10:43:09 EST
Created attachment 148111 [details]
rpmbuild output as user
Comment 19 Dawid Zamirski 2007-02-15 10:43:59 EST
Created attachment 148112 [details]
rpmbuild as root
Comment 20 Marcel Edward Verhagen 2007-02-15 11:23:48 EST
hmmzzz apparently the 64 bit does have a /usr/lib dir since make install creates
this dir automaticly and the rpmbuild is located in /usr/lib.

The good news is that the configuring, the build and the make install to the
/var/tmp dir seems to work ok.

However the files wich are installed in the rpm have to be manually entered in
the spec file in the %files section. Since the rpmbuild from the src package on
the 64  bit log indicates the should be used two different lib locations, one
/usr/lib64 for xorg and one /usr/lib for the others I have added a  %define to
make this happen


http://meverhagen.nl/fc6/i386/linuxwacom-7.6.1.spec
Comment 21 Marcel Edward Verhagen 2007-02-15 11:48:44 EST
oeps forgot the link to the new src package:
http://meverhagen.nl/fc6/i386/linuxwacom-0.7.4_4-3.9.1.src.rpm
Comment 22 Dawid Zamirski 2007-02-15 12:27:58 EST
I just tried the new package and I'm still getting rpath errors. I have added
--diable-rpath to ./configure in the spec fiel but still no go :-(

Here is output of rpmbuild --rebuild linuxwacom-0.7.4_4-3.9.1.src.rpm  | grep -i
rpath:

/bin/sh ../../libtool --tag=CC --mode=link gcc -Wall -g -O2 -D__amd64__   -o
libwacomxi.la -rpath /usr/lib/TkXInput -no-undefined wacomxi.lo -L/usr/lib64
-lX11 -lXi 
/bin/sh ../../libtool --tag=CC --mode=link gcc -Wall -pedantic -g -O2
-D__amd64__   -o libwacomcfg.la -rpath /usr/lib -no-undefined -version-info
0:1:0 wacomcfg.lo -L/usr/lib64 -lX11 -lXi 
gcc -Wall -pedantic -g -O2 -D__amd64__ -o .libs/xsetwacom xsetwacom.o 
./.libs/libwacomcfg.so -L/usr/lib64 -lX11 -lXi -Wl,--rpath -Wl,/usr/lib
Comment 23 Marcel Edward Verhagen 2007-02-16 16:57:21 EST
oke
a simple howto to simplify the problem.

Open the src rpm package in mc of file-roller (enter CONTENTS.cpio) and extract
all the files to the /usr/src/redhat/SOURCES dir

The one file wich matters is the
http://meverhagen.nl/fc6/i386/linuxwacom-7.6.1.spec spec file. Extract it to the
/usr/src/redhat/SPECS

run:
rpmbuild -ba /usr/src/redhat/SPECS/linuxwacom-7.6.1.spec

And then you should end up with a working rpm package for 64 bit

If this fails enter this in the console 

cd /usr/src/redhat/BUILD/linuxwacom-0.7.6-4
./configure --prefix=/usr --with-xorg-sdk=/usr --with-tcl=/usr --with-tk=/usr
--enable-xserver64
make
make install

ofcouse you can tweak the ./configure line. It should be possible to configure
without any options ! In this case you should create a few symlinks from 
/usr/lib/tk8.4 dir to /usr/local/lib/tk8.4 and a symlink from /usr/lib/tcl8.4 to
/usr/local/lib/tcl8.4 In this case it will install into /usr/local/lib and you
will have to manually copy the wacomcpl an wacomcpl-exec files from the
src/wacomxi to /usr/bin dir. The lib dirs could be somehow different. But thats
how I got it to work years ago by a ./configure and creating a few symlinks.
(and ofcourse by editing the xorg.conf file, but for this I think the
http://kxgenerator.xt.pl/ should be do the trick. A gui for the xorg.conf file.
This doesn't work yet for the linuxwacom sections. however a little development
should fix this. I hope I will find the time to help a bit with the development
of this part of kxgenerator) 
Comment 24 Marcel Edward Verhagen 2007-02-18 00:21:12 EST
So the spec seems to work for the i386, but not for 64 bit.
Has anyone got the wacomcpl to run on 64 bit ? (self compiled or from a rpm orso)

It's hard to make it work on different distributions. There are a number of reasons:

- The wacomcpl is using the non standard tk/tcl libs. 
- The @configure macro messes up the compilation on i386. The resulting libs
with the ./configure creates different libs wich do work on i386
- The /dev/input/wacom symlink should be present or it will not work. (this is a
bug, since the event3 is always present, but renaming the 60-wacom.rules to
49-wacom.rules does the trick, it's a ugly hack but it works !)
- Another problem is that the wacomcpl-exec tool isn't compiled but it is a
precompiled executable. However this seems to be work in progress. I don't know
what development evirionment they use to compile it. But if this executable
fails this should backported to the linuxwacom mailing list. This is something
the linuxwacom developers should fix.
- The possible tool wich can be used to create and maintain the xorg.conf file
is work in progress. I recommend to wait with packinging until it has reached a
stable state. (why isn't there a gui for the xorg.conf anyway ?)
- I haven't got a clean system. Everything works but it a handicap when
packaging things wich should work on other pc.  
Comment 25 Dawid Zamirski 2007-02-18 13:37:49 EST
Marcel,

I have just played with it and I built the drivers from source. After trying
this the Xorg crashed with the same error as in the 2nd attachemnt. I also tried
this with beta driver 0.7.7 but X still crashed. Then I have downgraded my glibc
2.5-10 from updates to 2.5-3  that comes with core and after that the drivers
from both your rpm and source itself work ok, execept build problems as non
root. Since I got the driver itself working now, I'll get back to you when I
find a way to solve those rpath issues with rpm.
Comment 26 Adam Jackson 2007-05-11 20:18:10 EDT
Why is this a review request?  linuxwacom has been in core since forever.
Comment 27 Marcel Edward Verhagen 2007-05-12 02:40:23 EDT
A smal part of the linuxwacom driver was in.
But without the admin tools needed to get the hardware to work.

This review is about a linuxwacom rpm with the admin tools and the support for
the features of the hardware included.

I will make a fc7 rpm a few days after the fc7 release.
Comment 28 Jason Tibbitts 2007-07-06 17:32:47 EDT
I wish I could help here, but I haven't the hardware, and even if I had the
hardware I'm not sure I understand all the issues.  So let me try:

Upstream talks about a kernel driver, but it's not packaged here.  From ajax's
comment above I assume it's already present as
/lib/mocules/*/kernel/drivers/input/tablet/wacom.ko.

This package includes an X driver.  Which is more in ajax's domain (or
Kristian's, I guess).  I don't see any existing xorg driver package for this,
although it begs the question of whether the X driver (and its manpage) should
be in a package named xorg-x11-drv-wacom like all the other X drivers.

Then there's the control software, which is probably OK as is as long as it's
working now without having to downgrade glibc as detailed in comment 25.

Finally, I note that 0.7.8 is out, and also that f7 has now been released.
Comment 29 Marcel Edward Verhagen 2007-07-07 08:43:34 EDT
Yes you have got a point.

I have been working on this one, but it is hard to get it running.

Now X11 crashes on my 64 bit laptop when the wacom graphire isn't connected.
This doesn't happen op the 32bit version.

Although I can get the control software to run on a 64bit pc, the is no need to
downgrade glibc.

I configure the 64bit version with 
./configure --enable-tabletdev --prefix=/usr --enable-wacom

I now outcomment the wacom part in the xorg.conf file manually.

I haven't tried the 0.7.8 version yet,but I will soon ...
Comment 30 Gian Paolo Mureddu 2007-07-20 17:20:42 EDT
I got to this discussion by chance when searching on Bugzilla and I was about to
apply an RFE for updated versions of the Wacom drivers as they are made
available by the linuxwacom project. At any rate, I have been successful to run
the linuxwacom on several other computers (raging from FC5/6 and now my main
system with Fedora 7). I have a little experience building RPM packages and have
been mostly successful installing the linuxwacom drivers in 64 and 32-bit
systems alike. Currently, though I'm running the bundled 0.7.4_1 package that is
part of "Core" and this has some problems when using it namely, the cursor
pointer vanishes in GDM to the lower right corner, or in a session the pointer
resets to "the origin" to the upper left corner when using any of the PAD
devices (buttons and wheel on a Graphire 4). My current setup is a 64-bit Fedora
7 installation, and I'd be willing to look into what could be causing the
problems encountered along the way to release this updated version of the driver.

Since version 0.7.8 has been already released, and the developers of the project
recommend using it, I'll see if I can get it to work fully (i.e. also building
the X driver, which I usually don't). I'll share my findings in the next couple
of hours as I tamper with it.
Comment 31 Gian Paolo Mureddu 2007-07-20 18:16:46 EDT
In my first run down with the package I found a couple things:

* Did not know there was a binary-only file: wacomcpl-exec, which ](IMO) should
be installed from the "prebuilt" directory of the source instead of supplying it
to the SOURCES directory.

* Even though the shipped udev rules file is named 60-wacom.rules, it is
installed as 49-wacom.rules, fixing the hijack of the INPUT rules by rule 50
(nice, a long needed fix)

* For some reason all the development libraries (I'm building for x86_64) seem
to go to /usr/lib instead of /usr/lib64, this yields an error when doing an
'rpmbuild -ba' or 'rpmbuild -bb' of the spec as the files are not found for the
architecture:

RPM build errors:
    File not found by glob: /var/tmp/linuxwacom-0.7.8_1-1.0/usr/lib64/libwacomcfg*.a
    File not found by glob:
/var/tmp/linuxwacom-0.7.8_1-1.0/usr/lib64/libwacomcfg*.so
 
Maybe this has to do with the "%define _alllib  /usr/lib"?
Comment 32 Gian Paolo Mureddu 2007-07-20 18:43:47 EDT
Correcting the problem for the libwacomcfg* files was as easy as to add another
variable to the 64-bits test:

LIB64=--libdir=/usr/lib64

This fixes the path for the those libraries... Leaving the %define _alllib
/usr/lib definition is required for the TkXInput files. I'm in the process of
testing the rpms on my system, here they are:

http://basilides.homeip.net/RPMS/SPECS/linuxwacom-7.8.spec
http://basilides.homeip.net/RPMS/linuxwacom-0.7.8_1-1.x86_64.rpm
http://basilides.homeip.net/RPMS/linuxwacom-devel-0.7.8_1-1.x86_64.rpm
http://basilides.homeip.net/RPMS/linuxwacom-debuginfo-0.7.8_1-1.x86_64.rpm

Please keep in mind this is my home server and the upload speed is 256kbps, and
I don't have anywhere else to host these files.
Comment 33 Gian Paolo Mureddu 2007-07-20 18:46:16 EDT
Forgot to include the link for the .src.rpm:

http://basilides.homeip.net/RPMS/linuxwacom-0.7.8_1-1.src.rpm
Comment 34 Gian Paolo Mureddu 2007-07-20 19:05:10 EDT
I can confirm the package builds and install, and for what I've been able to see
it also works reasonably fine. Wacomcpl works just fine.
Comment 35 Christopher Brown 2007-07-23 10:48:51 EDT
I have updated the spec file.

http://snecker.fedorapeople.org/linuxwacom.spec

Mainly rpmlint cleanups but some errors which would have been blockers for
approval. Unfortunately wacomcpl does *not* work for me - I'm currently
investigating.
Comment 36 Jason Tibbitts 2007-07-27 02:47:17 EDT
I'm a bit confused because there's currently a linuxwacom package in Fedora that
contains a good portion of what this package contains.

I understand that package doesn't contain everything the proposed package
contains.  However, it seems to me that the best thing to do would be to work
with the maintainers of the current linuxwacom package to get those extra bits
included.  Failing that, this package would need to be renamed and those files
which conflict with linuxwacom would need to be removed.
Comment 37 Christopher Brown 2007-07-27 03:55:18 EDT
This review request was created AFAICS because the linuxwacom package already in
fedora:

a) Doesn't follow upstream closely enough
b) Does not provide the required functionality - ie. wacomcpl

The maintainer has stated in:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=219060

that he will update to 0.7.8 soon however.
Comment 38 Jason Tibbitts 2007-07-27 21:48:59 EDT
So is there any point in keeping this ticket open, given that the package
submitted for review can never be approved?  Perhaps the submitter could offer
to co-maintain the existing linuxwacom package that's already in Fedora?
Comment 39 Marcel Edward Verhagen 2007-07-28 02:41:59 EDT
Yes close this ticket, it has had it's use.

There are 18 new wacom reports since I filed this request. So I ques there now
are plenty people working on this one.

And yes I got the wacom tools running on 64 bit (it doesn't do this on 32 bit),
but I can't figure out why the X-server is crashing when the tablet isn't
connected. (outcommenting some lines in the xorg.conf file after the x-server helps)

Anyhow I have got little time, I am building a new world in secondlife and this
consumes lots of my time 

Note You need to log in before you can comment on or make changes to this bug.