Bug 220726 - soft-safe -> soft-unsafe lock order detected (selinux/ssh)
soft-safe -> soft-unsafe lock order detected (selinux/ssh)
Status: CLOSED DUPLICATE of bug 220966
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-24 13:07 EST by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 09:39:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (9.01 KB, text/plain)
2006-12-24 13:07 EST, Ralf Ertzinger
no flags Details
2905 /var/log/messages (67.29 KB, text/plain)
2007-01-08 11:51 EST, dex
no flags Details
kernel panic on shutdown (1.18 MB, image/jpeg)
2007-01-08 11:59 EST, dex
no flags Details
the other part of panic shot (1.24 MB, image/jpeg)
2007-01-08 12:02 EST, dex
no flags Details

  None (edit)
Description Ralf Ertzinger 2006-12-24 13:07:43 EST
Description of problem:
ssh'ing into a machine running 2.6.19-1.2891.fc7 produces the log messages
attached to this bug.
selinux is configured as permissive,targetted

The ssh connection works afterwards.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2891.fc7

How reproducible:
Always

Steps to Reproduce:
1. boot kernel
2. ssh into machine
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ralf Ertzinger 2006-12-24 13:07:43 EST
Created attachment 144345 [details]
dmesg output
Comment 2 Deji Akingunola 2007-01-04 22:04:03 EST
I'm seeing exactly the same message when I logged into 2.6.19-1.2904.fc7 on
x86_64, except its Xorg instead of ssh in dmesg output of comment#1. The system
still boot and logon on to the desktop though, only that usb drives don't
automount. Same usb drive automounts when booted into the 2.6.20rc3-rt kernel. 
Comment 3 dex 2007-01-08 11:51:45 EST
Created attachment 145073 [details]
2905 /var/log/messages

2905 /var/log/messages
Comment 4 dex 2007-01-08 11:54:11 EST
today I caught same error as comment #1 with sendmail can also confirm with ssh
also & kernel 2.6.19-1.2905.
also all kernels since 2.6.18-1.2849.fc6 crash on exit only got 2 screenshots no
logs may be related! full dmesg is included.
hardware: athlon-xp 2500 NVidia nforce2 chipset.  
Comment 5 dex 2007-01-08 11:59:15 EST
Created attachment 145075 [details]
kernel panic on shutdown
Comment 6 dex 2007-01-08 12:02:23 EST
Created attachment 145076 [details]
the other part of panic shot
Comment 7 Eric Paris 2007-01-09 09:39:34 EST
dex, the 2 panics from comment 5 and 6 appear to be unrelated to this particular
issues.  would you mind filing them as a new BZ?

As for the issues discovered by the lock dependancy code in comments 1 and 3
this should be resolved upstream.  Until you get a fixed kernel it is possible
your machine will deadlock.  Test fedora kernels with a fix can be found at
http://people.redhat.com/eparis/BZ220966

I am going to mark this bug as a dup of 220966

*** This bug has been marked as a duplicate of 220966 ***
Comment 8 dex 2007-01-09 10:59:08 EST
2.6.19-1.2906.fc7 sorted the panic on shutdown from #5 #6(whoohoo!)
testing kernel from comment #7 
2.6.19-1.2906.fc7 didnt help lock dependancy still there. watching & reporting @
#220966 now.

Note You need to log in before you can comment on or make changes to this bug.