Bug 22073 - (Permedia 2) on RH7/Alpha graphical corruption and machine hang (Including during GNU installer!)
(Permedia 2) on RH7/Alpha graphical corruption and machine hang (Including du...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-11 15:56 EST by jpranevich
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 13:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jpranevich 2000-12-11 15:56:13 EST
I just installed RedHat 7.0 on my Alpha workstation, in preparation for
actually using it "in the field" on production hardware. However, when
doing the install, I noticed some very *severe* graphical issues during the
GUI-based install. For example, most images and scroll bars would appear as
black and white horizontal or verticle bars. Text field would appear solid
black, etc. Eventually, the install would hang the box hard and I would
need to reboot using the power switch.

Installing with text mode seems to have solved that problem and when I
enter X on the new install (with the chipset seemingly correctly detected),
I not not get the massive graphical anomalies. However, occasionally, a
menu will not render properly or a line of text will not appear. Within
several minutes of exceedingly light use, the machine would hang. Any
complicated graphical work (opening Netscape, viewing three pages) would
definately cause the box to hang.

This problem did not occur with RedHat 6.2 on the same hardware. However, a
might lighter version of the problem was observed on RedHat 6.1, but an
upgrade to 6.2 fixed those issues. As a diagnostic step, I have upgraded
the machine to the latest firmware revision. I have also verified that the
board's firmware does not need upgrading.

The machine itself is a Digital Professional Workstation 600au. The video
card is a ELSA Gloria Synergy, based on 3Dlabs Permedia 2 chipset.
(Detected as a Texas Instruments TVP4020 Permedia 2 (rev 1)) The card's
firmware is up to date: v7.03.04. It has 8 megs of video RAM. (I have tried
configuring 2, 4, and 8 megs of RAM in the configurator without change.)
The processor on this box is a Alpha 21164 running at 600mhz. It has 64
megs of RAM. Using "NoAccel" doesn't seem to help.
Comment 1 jpranevich 2001-02-06 19:05:33 EST
Actually, using the XFree4.x RPMs and using their variant of NoAccel seems to 
get it working okay. I still have occasional reboots and issues, but those 
could be general RH7.0 instability rather than a video card option. The non-
accellerated option is *much* slower than the accellerated one. I can give you 
my config file to show you a working config.

I would think that the graphical installer would default to a safe setting. I'm 
surprised it would have these issues.
Comment 2 Mike A. Harris 2001-04-02 13:01:01 EDT
No, if you're having random reboots they are definitely not "general
instability in Red Hat Linux 7.0".  They are almost certainly related
to XFree86.  I've got some patches from compaq that might fix the problems.

The permedia driver is quite buggy.  Are you willing to test some new RPMS?
I'll whip 'em up for ya if so.
Comment 3 jpranevich 2001-04-02 13:51:09 EDT
It's been two months since I put in the ticket, here's how things stand now:

I've been running successfully with RH7.0 with accelleration turned off. I will 
occasionally get machine hangs, and I will occasionally get XServer hangs. 
(Ctrl+Alt+Backspace solves those) The hangs almost always happen during a 
screensaver, and not necessarily one of the GL ones. HOWEVER, the hangs don't 
happen often enough for me to readily be able to test a new RPM with 
accelleration off. (I could test, but I can't guarantee that I'd see the 
problem in a reasonable amount of time.)

With accelleration turned on, I will see the hangs. (Probably-- I haven't tried 
it in a couple months, but I don't see any reason why it would suddenly fix 
itself.) Is that what you'd like to test?
Comment 4 Mike A. Harris 2001-04-10 01:01:35 EDT
A *MAJOR* new update to the Permedia driver has just been incorporated
into XFree86-4.0.3-8.  The patches are from Compaq, and fix numerous
problems on Alpha, as well as other platforms.  These packages are available
for download at:   http://people.redhat.com/mharris
Please close the bug report after confirming that it does in fact fix the
problem for you, and ensure that you fill out new bug reports if you encounter
any new errors.  Thanks.
Comment 5 Mike A. Harris 2001-04-13 13:55:28 EDT
I mistakenly gave a bad URL above.  ;o(  The proper URL is:

ftp://people.redhat.com

Not http.  Please try out the latest code and let me know if this problem is
fixed now.
Comment 6 Mike A. Harris 2001-04-19 16:32:02 EDT
I've received reports back that the permedia/alpha bugs seem to be gone
in the latest XFree86 packages.  Please upgrade to the XFree86-4.0.3-9
release in rawhide or wait until our Seawolf Alpha release is finalized.

Note You need to log in before you can comment on or make changes to this bug.