Bug 220735 - rpm seqfault in rescue image in VMware
rpm seqfault in rescue image in VMware
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-25 00:37 EST by Eugene Kanter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 09:08:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2006-12-25 00:37:12 EST
Description of problem:

Rpm seqfaults in rescue image in VMware.

How reproducible:

always

Steps to Reproduce:
Installed FC6 in VMware beta 6 running on Windows XP and ran yum update.

Booted from rescue image, let rescue mount FC6 on /mnt/sysimage

Issued command

rpm -qa --root /mnt/sysimage
  
Actual results:

rpm segmentation faults or hangs

Expected results:

package list output.

Additional info:

Unable to reproduce using rescue image on a real P4 system with FC6 installed.
Unable to find any kind of rpm problems in VMware image after FC6 is booted.

I recall there were some vmware related problems but do not remember details.
However since rpm is working fine in VMware during installation and after system
is installed I don't see the reason why rpm shouldn't work in rescue image
unless something is broken in image or rpm.
Comment 1 Jeff Johnson 2006-12-26 08:17:57 EST
rpm runs under VMware, there's nothing wrto segfaults running FC6 under VMware.

The issue is likely the instabilities introduced by yum reopening an rpmdb thousands
of times per transaction, see many many other bugs against rpm in FC6.
Comment 2 Eugene Kanter 2006-12-26 13:12:07 EST
Before submitting this I read all FC6 related rpm bugs, there are many segfault
reports but all of them are in OS environment and not in rescue.

Let me repeat: I can run rpm install and query commands, yum updates and erases
in VMware without any issues whatsoever. However no rpm command work if rescue
image booted in the same VMware environment.

My impression was that rescue image environment (e.g. kernel, libc, etc.) is the
same as real OS. Isn't it?
Comment 3 Jeff Johnson 2007-04-10 21:32:33 EDT
What are the symptoms of "no rpm command works" with rescue mode in VMware?

Do
    rm -f /var/lib/rpm/__db*
to get rid of any stale locks or corrupted caches first.

Try running with -vv and attach the output of any failed command here.

NEEDINFO
Comment 4 Panu Matilainen 2007-08-10 09:08:59 EDT
IIRC the kernel in FC6 the installer/rescue image is bugged with the kernel
mmap() corruption issue. Not much that can be done about the released isos... 

The fact that you're not seeing it on installed systems doesn't necessarily mean
that much, took a while before I was able to reproduce the mmap() bug on any of
my systems back then. And once updates have been installed the issue will be
gone again, but no updates in rescue-mode.

If F7 rescue image fails similarly within VMware, then it's likely to be
something else instead (in which case feel free to reopen against devel).

Note You need to log in before you can comment on or make changes to this bug.