Bug 220752 - ps does not show all processes
ps does not show all processes
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Tomas Smetana
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-25 15:09 EST by Albert Cahalan
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 09:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Cahalan 2006-12-25 15:09:32 EST
Description of problem:

ps won't show all processes.

How reproducible:

100%, given the right conditions (which I did hit on a mildly overloaded
system at work -- I don't wish to be fixing procps at work though!)

Steps to Reproduce:
1. run ps

Additional info:

Upstream ps works perfectly and never had this horrible defect.
You do your customers a disservice when you add buggy crap to
your procps rpm.

I may be the upstream maintainer, but I'd rather not need to
be compiling my personal project at work.

It wouldn't kill you to wait for upstream to test patches properly.
Critical system binaries should not be full of bugs.

It's your buggy patches... you fix it.
Comment 1 Karel Zak 2006-12-25 17:54:37 EST
(In reply to comment #0)
 
> How reproducible:
> 
> 100%, given the right conditions (which I did hit on a mildly overloaded
> system at work -- I don't wish to be fixing procps at work though!)
> 
> Steps to Reproduce:
> 1. run ps

 Sorry, but this bug report is useless... You should provide more details how we
can reproduce your problem. Thanks.


Comment 2 Albert Cahalan 2006-12-26 00:12:35 EST
It would be better for you to review all your patches for bugs,
run some regression tests, run some stress tests, run valgrind,
and have some bright people do line-by-line code review. It's
more than a bit likely that you've added multiple bugs. The
word "unsupportable" comes to mind.

I found this while just trying to use the program, not while
making any special effort to find bugs. Maybe you'll get some
extra info when a well-paying RHEL customer hits this one.
(this is probably in FC6, but no, I don't have time to test)

There may be conflicts of interest at my workplace. I really
don't want to be debugging procps at work.

To some extent, you tarnish my reputation when you add bugs.
This puts me in a rather bad mood. You also interrupted the
work I was doing via this bug. I'm working serious overtime
as it is, perhaps 80 hours this week if I have the stamina
for it.

If you can't find and fix your own bugs, maybe you shouldn't
be adding them in the first place. The upstream package does
work quite reliably without any added patches. It really is
that easy:

http://www.linuxfromscratch.org/lfs/view/development/chapter06/procps.html

Since I'm being a dumb user and all, got an easy way to make
Fedora think it has procps-9.9.9? I sure don't want to be
downgraded back to the broken version you're shipping.
I happen to expect that "ps" will list my processes.
Comment 3 Tomas Hoger 2007-02-12 09:11:55 EST
Albert, could you try to grep output of ps for your missing processes?

I've noticed, that ps (procps-3.2.7-8.2.fc6, started as ps -ef or ps aux) on my
FC6 system sorts it's output according to PID and not STIME!?!  Therefore, newly
started processes are not listed on last few lines of output as expected on
Linux, but they can be anywhere.

Is output sorting accoring to PID intended behavior?
Comment 4 Tomas Smetana 2007-05-14 09:45:35 EDT
I can't reproduce the problem and nobody else reports this. Since the submitter
did not provide any further information I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.