Bug 220779 - Request to compile in support for NFS export in FUSE
Request to compile in support for NFS export in FUSE
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-26 12:55 EST by Need Real Name
Modified: 2008-07-19 18:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-19 18:23:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-12-26 12:55:17 EST
Description of problem:

I have lately been using ntfs-3g to mount my winxp partitions which I would also
like to export across my network.

However, I believe that this requires support for NFS to be compiled into the
fuse module (according to README.NFS).

I believe that this is not (yet) supported under the Fedora Extras version of
Fuse. If it is supported, can you tell me what I need to do to make it work

Any chance of adding such support in the (near) future?


Specifically,
I am in the current situation. If I mount my windows partitions using 'ntfs'
then I have no trouble exporting them as nfs shares. However, if I mount the
windows partitions using ntfs-3g (which uses FUSE) then they are no longer
properly exported. Specifically, I get the error message:
    mount: 192.168.1.100:/mnt/winxp failed, reason given by server:
    Permission denied

I tried adding fsid=NNN as recommended in the README.NFS but that didn't help,
leading me to assume that maybe NFS support is not (yet) compiled into the fuse
module.
Comment 1 Need Real Name 2007-01-14 12:52:31 EST
Any chance of making this work????
Comment 2 Peter Lemenkov 2007-03-02 15:23:08 EST
> Any chance of making this work????

In any case there is a chance that it will work )
Possibly someone writes a HOWTO for this?

I personally don't face such troubles 'cause don't share FUSE-filesystems via
network.
Comment 3 Need Real Name 2007-03-27 20:31:14 EDT
Has this been fixed?
Any interest in fixing it?
Comment 4 Peter Lemenkov 2007-04-11 15:52:21 EDT
(In reply to comment #3)
> Has this been fixed?

I can't reproduce it personally (see reason above). Can you?

> Any interest in fixing it?

Sure, but I don't know how (1sr reason) and personally don't need such fix
because I don't use NFS with FUSE (2nd reason).

Maybe someone could fix?
Comment 5 Peter Lemenkov 2007-06-06 09:31:12 EDT
Does this bug still exists with newer kernels?
Comment 6 Peter Lemenkov 2008-01-23 04:21:43 EST
Ping.
Comment 7 Peter Lemenkov 2008-07-12 01:15:15 EDT
Assigning to kernel team. 
Comment 8 Dave Jones 2008-07-12 01:51:54 EDT
This report makes it sound like we've forgotten to turn on some option.
To the best of my knowledge, there is no option.  If FUSE doesn't support NFS
exporting, it's a shortcoming that needs to be addressed upstream.
Comment 9 Neil Horman 2008-07-12 07:29:55 EDT
Thats right, making an fielsystem exportable requires that it have a NON-null
export_ops field in its superblock.  FUSE currently has no export_ops defined.
Comment 10 Chuck Ebbert 2008-07-19 18:23:39 EDT
I'm pretty sure the FUSE developer knows about this problem already.

Note You need to log in before you can comment on or make changes to this bug.