Bug 22078 - problem with local networks
Summary: problem with local networks
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: caching-nameserver   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-11 21:52 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-11 21:52:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-12-11 21:52:44 UTC
The caching nameserver is installed
and /etc/resolv.conf is
----------------
search localdomain 
nameserver 127.0.0.1
----------------

Many programs (like samba, netstat and etc)
seems doing DNS lookup even on non-routed IPs
like 192.168.1.71
They are probably made through caching nameserver.
The cachining nameserver seems doing a lookup of these 
addresses and this caused huge delay.
I think the caching nameserver should return the answer right 
away, without all these very annoing delays on 
non-routed  networks when some tools are used.

I think something should be fixed so netstat -a ; ipchains -L and etc
return faster than it is now. Now it is extremely slow.
in the same time netstat -an (-n do not resolve) is extremely fast.

Comment 1 Pekka Savola 2000-12-12 16:30:35 UTC
This is as designed.

You should run a full-fledged DNS for those non-routable IP-addresses 
or add them to /etc/hosts.

Comment 2 Need Real Name 2000-12-12 16:53:31 UTC
Is there a way to add to /etc/hosts
entire subnet, otherwise it may be too many hosts to add.

Comment 3 Pekka Savola 2000-12-12 17:23:19 UTC
In that kind of scenario, I recommend setting up a DNS server.  Basically
"distributes" one centrally managed "/etc/hosts" to all systems.  You only
need to define those hosts on your server.

There are a few HOWTO's and guides around.  The definitions will be in /etc/named.conf
and under /var/named.


Comment 4 Dave Wysochanski 2007-01-24 01:19:40 UTC
*** Bug 224079 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.