Bug 22080 - RedHat 7 Ships with Gcc 2.96
Summary: RedHat 7 Ships with Gcc 2.96
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-11 22:27 UTC by Mark Cuss
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-11 22:27:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Cuss 2000-12-11 22:27:06 UTC
RedHat 7 ships with GCC version 2.96.  After experiencing compatability 
issues with this software, some research and contacts uncovered the fact 
that GCC v2.96 is a beta version of the new and upcoming GCC v3 and was 
never intended to be released as a development suite and is not forward or 
backward compatable with previous or upcoming versions.  

Check out http://gcc.gnu.org/gcc-2.96.html for more information

Why was Redhat 7, touted as a development platform, shipped with a never 
meant to be released version of the C compiler?

Comment 1 Jakub Jelinek 2000-12-11 22:40:12 UTC
If you encounter any bugs, please file them here, but the fact that we have
released this compiler is not a bug, it was intentional, see
Richard Henderson's explanation in lwn.net archives for why we decided
to ship this.
If you talk about C++ binary compatibility, then no g++ so far
has been compatible with other major g++ version (2.7.x vs. 2.91
vs 2.95.x etc.).
C should be binary compatible on ia32 (maybe with exceptions of
-mregparm in some cases).


Note You need to log in before you can comment on or make changes to this bug.