Bug 220802 - rhpl emits a DeprecationWarning - "raising a string exception is deprecated"
rhpl emits a DeprecationWarning - "raising a string exception is deprecated"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 230018 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2006-12-27 02:20 EST by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-21 16:12:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mayank Jain 2006-12-27 02:20:48 EST
Description of problem:
RHPL emits a DeprecationWarning - "raising a string exception is deprecated".

-------------------------
[majain@localhost ~]$ neat
Bonobo accessibility support initialized
GTK Accessibility Module initialized

** (system-config-network:5866): WARNING **: AT_SPI_REGISTRY was not started at
session startup.

** (system-config-network:5866): WARNING **: IOR not set.

** (system-config-network:5866): WARNING **: Could not locate registry
/usr/lib/python2.5/site-packages/rhpl/Conf.py:275: DeprecationWarning: raising a
string exception is deprecated
  raise FileMissing, self.filename + ' does not exist.'
-------------------------

Version-Release number of selected component (if applicable):
rhpl-0.196-1

How reproducible:
Everytime

Steps to Reproduce:
Actually, the steps to reproduce can be a bit tricky... As shown in this bug
report, if your AR_SPI_REGISTRY gives an error, neat will show you the
deprecation warning. Try running "neat" from the console & you might get the
warning.
  
Actual results:
Deprecation warning

Expected results:
No warning

Additional info:
system-config-network-1.3.96-1.fc6
Adding katzj to the CC list (brew says rhpl is owned by katzj)
Comment 3 Chris Lumens 2007-02-21 16:12:28 EST
This will be fixed in the next build of rhpl.  Thanks for the bug report.
Comment 4 Mayank Jain 2007-02-22 00:35:56 EST
Thanks guys :)
Comment 5 Chris Lumens 2007-02-26 10:02:28 EST
*** Bug 230018 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.