This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 220807 - convert gif->png results in bad output
convert gif->png results in bad output
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Norm Murray
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-27 05:57 EST by Rolf Fokkens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-11 05:35:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Original p1.png file (3.37 KB, image/png)
2006-12-27 05:57 EST, Rolf Fokkens
no flags Details
Intermediate result p2.gif (1.18 KB, image/gif)
2006-12-27 05:58 EST, Rolf Fokkens
no flags Details
Unexpected result p3.png (670 bytes, image/png)
2006-12-27 05:58 EST, Rolf Fokkens
no flags Details

  None (edit)
Description Rolf Fokkens 2006-12-27 05:57:26 EST
Description of problem:
Conversion of gif -> png results in bad output. The result seems to be
horizontaly compressed with nonsense on the right to fill up to the original width.

Version-Release number of selected component (if applicable):
ImageMagick-6.2.8.0-3.fc6.1

How reproducible: 100%

Steps to Reproduce:
1. view p1.png (it's a transparent rectangle with a red rectangle within)
2. convert p1.png +map p2.gif
3. convert p2.gif p3.png
4. View the unexpected result in p3.png

  
Actual results:
p3.png is a messed up version of p1.png

Expected results:
p3.png an p1.png should resemble closely

Additional info:
Comment 1 Rolf Fokkens 2006-12-27 05:57:26 EST
Created attachment 144391 [details]
Original p1.png file
Comment 2 Rolf Fokkens 2006-12-27 05:58:13 EST
Created attachment 144392 [details]
Intermediate result p2.gif
Comment 3 Rolf Fokkens 2006-12-27 05:58:58 EST
Created attachment 144393 [details]
Unexpected result p3.png
Comment 4 Rolf Fokkens 2007-08-11 05:35:03 EDT
The problem is no longer there with ImageMagick-6.3.2.9-3.fc7

Note You need to log in before you can comment on or make changes to this bug.