Bug 220818 - vulnerable for DoS and info. leak
vulnerable for DoS and info. leak
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wordpress (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
http://secunia.com/advisories/22683/
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-27 09:51 EST by Kim Bisgaard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-27 11:17:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kim Bisgaard 2006-12-27 09:51:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
Some vulnerabilities have been reported in Wordpress, which can be exploited by malicious users to gain knowledge of potentially sensitive information or cause a DoS (Denial of Service), and by malicious people to gain knowledge of sensitive information.

1) The /wp-admin/user-edit.php script does not correctly restrict access to the metadata of users. This can be exploited to list certain metadata information by passing the ID of a user in the "userid" parameter.

2) Input passed to various fields (e.g. the "first name" field in the profile page) is not properly sanitised before being unserialised. This can be exploited to cause a DoS by entering specially crafted strings.

3) Input passed to unspecified parameters in plugins/wp-db-backup.php is not properly sanitsed. This can be exploited to read arbitrary files via directory traversal attacks.

The vulnerabilities have been reported in versions prior to 2.0.5.

Solution:
Update to version 2.0.5.

Version-Release number of selected component (if applicable):
wordpress-2.0.4-3.fc5 and later (-4.fc6)

How reproducible:
Didn't try


Steps to Reproduce:
1.
2.
3.

Actual Results:


Expected Results:


Additional info:
CVE-2006-5705 (Secunia mirror)
CVE-2006-6016 (Secunia mirror)
CVE-2006-6017 (Secunia mirror)
Comment 1 John Berninger 2006-12-27 11:17:45 EST
Update to 2.0.5
Comment 2 Kim Bisgaard 2006-12-28 04:21:46 EST
Do you mean to say that this security holes will not be fixed in fc5 and fc6 but
first in 4 months when fc7 hits the streets?

Then please remove the security flag, so that users know that they are vunerable.
Comment 3 John Berninger 2006-12-28 16:18:40 EST
No, the packages in FE5 and FE6 were updated to version 2.0.5 and thus are no
longer vulnerable per the description provided.

Note You need to log in before you can comment on or make changes to this bug.