Bug 220821 - Default PHP memory_limit should be increased on 64-bit platforms
Default PHP memory_limit should be increased on 64-bit platforms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-27 10:21 EST by Elliot Lee
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.2.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 09:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2006-12-27 10:21:58 EST
Because 64-bit pointers & longs take up more memory, larger PHP scripts will not
run successfully on 64-bit platforms with default PHP configuration, even though
the same configuration allows them to run on 32-bit platforms. This is because
the memory_limit setting in /etc/php.ini is the same on both 32-bit and 64-bit
platforms.

The memory limit on 64-bit platforms should be 1.5x to 2x the limit on 32-bit
platforms.
Comment 1 Joe Orton 2007-01-03 07:51:31 EST
We've had fewer reports of memory_limit issues since the default was bumped to
16M everywhere (FC6) - were you still seeing this type of problem with the 16M
default?
Comment 2 Elliot Lee 2007-01-07 11:02:45 EST
Yes; I had to bump the limit up to 32M to get things to work on x86_64. On i386,
16M seems to work OK, and I'm sure that limit is more than enough for most people.

The main point I was making was that if the limit is N megabytes on a 32-bit
platform, it should be N*2 megabytes on a 64-bit platform.
Comment 3 Joe Orton 2007-03-12 09:16:22 EDT
Using the N*2 value as one-size-works-everywhere is simpler; 32M seems a
reasonable stab in the dark; upstream bumped to 128M which seems too high.  This
was done in Raw Hide, thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.