Bug 220840 - valgrind missing BuildReq for gdb
valgrind missing BuildReq for gdb
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: valgrind (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 240477 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-27 15:02 EST by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 07:20:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Tromey 2006-12-27 15:02:02 EST
Today I tried using 'valgrind --db-attach=yes'.
This printed an error message about the command '-nw'
not being found.

I think this happens because valgrind.spec does not
have a BuildReq on gdb.  This means that the
AC_PATH_PROG in valgrind's configure.in ends up
substituting an empty string instead of a path to gdb.

A workaround is to specify --db-command manually.
Comment 1 Jakub Jelinek 2007-05-19 04:05:39 EDT
*** Bug 240477 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2007-06-28 07:20:59 EDT
Should be fixed in valgrind-3.2.3-4 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.