Bug 220855 - crash when trying to debug git problem
crash when trying to debug git problem
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-12-27 20:22 EST by Horst H. von Brand
Modified: 2008-06-04 15:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-04 15:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Relevant lines from /var/log/messages (5.73 KB, text/plain)
2006-12-27 20:22 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2006-12-27 20:22:51 EST
Description of problem:
I tried to debug a git problem (with self-built git executable (from the
upstream SRPM), and curl from the distro). I installed the relevant debuginfo
packages, fired up gdb:

  gdb /usr/bin/git-http-fetch

I gave "break main" and then "run -v -a -w heads/master heads/master
http://dmlb2000.homelinux.org/~dmlb2000/git-repos/local/castfs.git/", all in a
gnome-terminal. A lot of "syslog" lines scrolled by, I tried to copy&paste them,
but the machine froze (CapsLock and mouse pointer still functional, nothing
else). Could shut down by the powerswitch, but not cleanly.

Version-Release number of selected component (if applicable):

How reproducible:
Happened once, might try again later...

Steps to Reproduce:
Actual results:

Expected results:
Being able to debug...

Additional info:
Had ipw3945-1.1.3 module (plus the 3 patches for kernel 2.9.20) loaded when the
crash happened.
Comment 1 Horst H. von Brand 2006-12-27 20:22:52 EST
Created attachment 144432 [details]
Relevant lines from /var/log/messages
Comment 2 Horst H. von Brand 2006-12-27 21:18:31 EST
OK, tried the same again. Again the same kernel messages, but the box didn't
freeze this time.
Comment 3 Horst H. von Brand 2006-12-27 21:28:21 EST
Nope. The box froze when doing a "rpm -q curl" a bit after reporting the above :-(
Comment 4 Dave Jones 2007-12-10 16:02:44 EST
yowch, we let this one sit quite a while without investigating.   Does this
still reproduce on 2.6.23 kernels by any chance ?
Comment 5 Horst H. von Brand 2008-01-11 08:47:39 EST
Nothing similar has happened again. But then again, I have been doing other
stuff lately...
Comment 6 Bug Zapper 2008-05-13 22:31:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 7 Dave Jones 2008-06-04 15:30:33 EDT
ok, if it (or similar) happens again, let us know (and we'll try to be a bit
more on the ball next time).


Note You need to log in before you can comment on or make changes to this bug.