Bug 220903 - gtk_label_set_text leaks
gtk_label_set_text leaks
Status: CLOSED DUPLICATE of bug 222260
Product: Fedora
Classification: Fedora
Component: gtk+ (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-28 11:54 EST by David L.
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 16:28:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of memory leak (694 bytes, text/plain)
2006-12-28 11:54 EST, David L.
no flags Details
valgrind output (2.68 KB, text/plain)
2007-01-10 18:28 EST, David L.
no flags Details

  None (edit)
Description David L. 2006-12-28 11:54:22 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. compile and run the attached example
2. 
3.
  
Actual results:
leaks memory with gtk version gtk2-2.10.4-8.fc6

Expected results:
doesn't leak memory

Additional info:
Comment 1 David L. 2006-12-28 11:54:23 EST
Created attachment 144477 [details]
example of memory leak
Comment 2 Matthias Clasen 2007-01-08 10:52:26 EST
I don't see any leak here ?

Have you tried running under valgrind, to get an idea what may be leaked ?
Comment 3 David L. 2007-01-10 18:28:12 EST
Created attachment 145294 [details]
valgrind output

Here's the output of valgrind on my system... it doesn't continuously print any

memory errors, but the memory usage does go up forever and valgrind does report
some lost bytes.
Comment 4 Davyd 2007-01-11 02:28:54 EST
I'm wondering if this is the same as bug 222260.

David L, you should run your valgrind with --leak-check=yes
Comment 5 David L. 2007-01-16 18:10:36 EST
I tried running valgrind with --leak-check=yes and didn't see any difference. 
The memory usage reported by top is still increasing but I don't see additional
errors reported by valgrind after the initial few.  By the way, somebody on the
gtk mailing list reproduced this bug with the fc6 version of gtk but said it
didn't happen with the latest non-redhat gtk.
Comment 6 Matthias Clasen 2007-02-02 16:28:59 EST
I'm going to assume this was the same as bug 222260

*** This bug has been marked as a duplicate of 222260 ***

Note You need to log in before you can comment on or make changes to this bug.