This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 220925 - when I insmod kernel module I build it fails due to version magic mismatch
when I insmod kernel module I build it fails due to version magic mismatch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-28 17:25 EST by Paolo Galtieri
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-29 00:56:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpuinfo and /etc/rpm/platform info (752 bytes, text/plain)
2006-12-28 17:25 EST, Paolo Galtieri
no flags Details
ls -l output of recent kernel module dirs showing links to i686 kernel trees (2.18 KB, application/octet-stream)
2006-12-29 01:46 EST, Paolo Galtieri
no flags Details
attempt to install i686 kernel (2.74 KB, text/plain)
2006-12-29 02:17 EST, Paolo Galtieri
no flags Details

  None (edit)
Description Paolo Galtieri 2006-12-28 17:25:44 EST
Description of problem:
I installed VMplayer of FC6 with latest set of patches.  When the vmplayer
config attempts to install the vmmon module it built I get the following message
in /var/log/messages:

Dec 28 06:49:18 localhost kernel: vmmon: version magic '2.6.18-1.2868.fc6 SMP
mod_unload 686 REGPARM 4KSTACKS gcc-4.1' should be '2.6.18-1.2868.fc6 SMP
mod_unload 586 REGPARM 4KSTACKS gcc-4.1'

Same thing happened when I built the uvcvideo kernel module and tried to insmod
it.  I worked around this one using the --force-vermagic option to modprobe.

Version-Release number of selected component (if applicable):
module-init-tools-3.3-0.pre1.4.17


How reproducible:
Install VMplayer and run the /usr/bin/vmware-config.pl when it tries to install
the vmmon module it will fail with the error described above.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Dec 28 06:49:18 localhost kernel: vmmon: version magic '2.6.18-1.2868.fc6 SMP
mod_unload 686 REGPARM 4KSTACKS gcc-4.1' should be '2.6.18-1.2868.fc6 SMP
mod_unload 586 REGPARM 4KSTACKS gcc-4.1'


Expected results:
The module should install cleanly


Additional info:
Comment 1 Paolo Galtieri 2006-12-28 17:25:44 EST
Created attachment 144500 [details]
cpuinfo and /etc/rpm/platform info
Comment 2 Jon Masters 2006-12-29 00:55:23 EST
You've got an i586 kernel installed and have built modules for an i686 kernel.
You'll need to install a correct kernel package or switch kernel-devel package -
and note that it's not possible to provide any support to users of such binary
modules anyway :-)

Jon.
Comment 3 Jon Masters 2006-12-29 00:56:29 EST
This is correct behavior for module-init-tools - refusing to load a module built
for the wrong kernel. The user needs to upgrade/switch kernel and dev. packages.
Comment 4 Paolo Galtieri 2006-12-29 01:46:03 EST
Created attachment 144526 [details]
ls -l output of recent kernel module dirs showing links to i686 kernel trees

The last 2 FC6 kernel updates create links to i686 dirs.  Yet when I build
kernel modules against those trees they wont install because of a version
mismatch.
Comment 5 Paolo Galtieri 2006-12-29 02:17:23 EST
Created attachment 144527 [details]
attempt to install i686 kernel

this is the out of a yum -y install kernel.i686

Note You need to log in before you can comment on or make changes to this bug.