Bug 220947 - Installing FC6 on platform with integrated ATI Rage XL AGP 2X Video Controller causes the X server to fail after firstboot
Installing FC6 on platform with integrated ATI Rage XL AGP 2X Video Controlle...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-29 09:07 EST by David Tonhofer
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-03 14:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf created by installation process (565 bytes, text/plain)
2006-12-29 09:07 EST, David Tonhofer
no flags Details
Xorg.0.log created by firstboot (66.77 KB, text/plain)
2006-12-29 09:08 EST, David Tonhofer
no flags Details
Xorg.0.log created during "telinit 5" (64.74 KB, text/plain)
2006-12-29 09:09 EST, David Tonhofer
no flags Details
Screenshot of the Welcome Screen (16.67 KB, image/jpeg)
2007-03-01 19:45 EST, David Tonhofer
no flags Details

  None (edit)
Description David Tonhofer 2006-12-29 09:07:53 EST
I have a Fujitsu-Siemens with an integrated "ATI Rage XL AGP 2X" which works
well under Red Hat ES 4 (and I think Fedora Core 4 and also Red Hat 9.0 ;-) 

Installation of Fedora Core 6 on that machine works well (as does the first
reboot) (** repeat: graphical installation works well up to the end **) but
after that, there is serious trouble with X11: the screen cannot set itself up
properly (seems to restart continuously) or else the screen sets itself up,
shows "gdm greeter" but also shows these "large rectangles of random pixel" that
indicate someone thought your video RAM was heap RAM that we all learned to love
back on the Amiga. Then the keyboard and mouse inputs are lost. 

Here is the procedure:

1) Installed FC6 with no hitch
2) Firstboot
   A boot, the switch to graphical boot fails (and keyboard/mouse input is lost)
   However, boot continues and after that we are back to the standard 
   graphical installation mode with the "Welcome" screen, which works.
   The attempt to switch to X11 graphical loging screen fails
   (and keyboard/mouse input is lost)
3) Reboot and boot with rescue disk
   Set GRAPHICAL=NO in /etc/sysconfig/init
   Set default runlevel 3 in /etc/inittab
   Save /mnt/sysimage/etc/X11/xorg.conf   as "xorg.conf.orig" (attached)
   Save /mnt/sysimage/var/log/Xorg.0.log  as "Xorg.0.log.orig" (attached)
4) Reboot, no X11 at boot now.
   Login an remove /etc/X11/xorg.cong
   telinit 5 to start X11, which fails.
   The graphical display shows in a partially massacred bitmap:
   "Greeter application appears to be crashing. Attempting to use a different
    one" (and keyboard/mouse input is lost)
   Saved /var/log/Xorg.0.log as "Xorg.0.log.telinit" (attached)
Comment 1 David Tonhofer 2006-12-29 09:07:53 EST
Created attachment 144541 [details]
xorg.conf created by installation process
Comment 2 David Tonhofer 2006-12-29 09:08:50 EST
Created attachment 144542 [details]
Xorg.0.log created by firstboot
Comment 3 David Tonhofer 2006-12-29 09:09:59 EST
Created attachment 144543 [details]
Xorg.0.log created during "telinit 5"
Comment 4 Adam Jackson 2007-01-29 18:49:48 EST
Can you reproduce this issue in FC7 test1?  (Once it's released, which should be
in the next day or two.)
Comment 5 David Tonhofer 2007-03-01 19:43:10 EST
Tested with FC7 - same problem at firstboot (screenshot attached). The red/green
rectangular object looks like the rendering of a random memory region.

....Additionally, the mouse (Logitech USB-PS/2 optical mouse) is correctly
recognized but behaves as it moved through molasses. Should I open a bug against
that?



Comment 6 David Tonhofer 2007-03-01 19:45:08 EST
Created attachment 149075 [details]
Screenshot of the Welcome Screen

Screenshot of the Fedora 7 Test 1 "Welcome Screen" taken with one of those
ridiculous "Mobile Cameras"
Comment 7 Bug Zapper 2008-04-03 14:50:21 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 8 David Tonhofer 2008-04-03 15:10:46 EDT
Agree with resolving this WONTFIX.

If I can ahold of the machine involved (thoroughly weird Fujitsu-Siemens
hardware that gave me no end of trouble) and test with a Fedora8 or later, I
will add a comment. But no promises.
Comment 9 Johan Kok 2008-05-03 14:44:53 EDT
Thank you for reporting back. This issue will be closed as WONTFIX. You can always reopen it when you're 
able to duplicate it with Fedora 8 or later.

Note You need to log in before you can comment on or make changes to this bug.