Bug 220983 - Evince (and xpdf) bad rendering of PDF file generated by ps2pdf
Evince (and xpdf) bad rendering of PDF file generated by ps2pdf
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-12-29 17:37 EST by Frank Cox
Modified: 2010-03-09 11:35 EST (History)
10 users (show)

See Also:
Fixed In Version: poppler-0.12.1-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-03-09 07:18:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Scribus document, graphic, .ps output and PDF file (24.21 KB, application/x-bzip2)
2006-12-29 17:37 EST, Frank Cox
no flags Details

  None (edit)
Description Frank Cox 2006-12-29 17:37:50 EST
Description of problem:
The attached PDF file was generated from Postscript output from Scribus and run
through ps2pdf.  A PDF of this document generated directly from Scribus can be
viewed with xpdf and evince.  A PDF of this document generated by ps2pdf from ps
output from Scribus can be viewed by Acrobat Reader on Linux, but the graphic is
a black box when viewed with xpdf and evince.

Version-Release number of selected component (if applicable):

How reproducible:
Every time.

Steps to Reproduce:
1."print-to-file" from Scribus
2. ps2pdf nameoffile.ps
3.evince nameoffile.pdf
Actual results:
The graphic is a black box

Expected results:
The graphic should say "Movie Cash"

Additional info:
Comment 1 Frank Cox 2006-12-29 17:37:51 EST
Created attachment 144564 [details]
Scribus document, graphic, .ps output and PDF file
Comment 2 Bug Zapper 2008-04-04 01:24:10 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 3 Barry K. Nathan 2008-04-19 23:24:35 EDT
I need to do some more thorough investigation of this bug this weekend, but I
can confirm that xpdf 3.00-16.el4 on Red Hat Enterprise Linux ES 4 Update 6
(with all updates applied) is affected. So, it still affects a Red Hat-family
distribution that is nowhere near end-of-life.

(BTW, the RHEL ES 4 U6 box in question is a print server, among other duties,
and I see the same bug show up on paper if I feed the PDF files to lpr instead
of viewing them with xpdf. In fact, this happens quite frequently when printing
web pages from Mac OS X 10.4.11/10.5.2 clients to this print server.)
Comment 4 Frank Cox 2008-04-20 00:12:41 EDT
The situation is still exactly as described in my initial bug report using
evince-2.20.2-1.fc8 on Fedora 8/x86_64.  The bug was initially reported on
Fedora 6/i386 but it still exists on Fedora 8/x86_64.

In other words, the bug still exists with no change since my initial report.
Comment 5 Barry K. Nathan 2008-04-20 03:16:58 EDT
FWIW, it looks like this bug is actually different than what I'm experiencing --
on a fully updated Debian etch system, your test case (the one attached to this
bug) fails, but my own test case (a PDF generated on Mac OS X 10.4.11) is
displayed properly and doesn't have the black boxes. (Both cases fail on my RHEL
ES 4 U6 box.)
Comment 6 sean 2008-10-26 11:06:27 EDT
Still a bug on F10, updated to Oct 26.


mangles it, acroread shows it.
Comment 7 Bug Zapper 2008-11-26 02:07:59 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 8 Frank Cox 2008-11-27 23:52:49 EST
The bug is still present in Fedora 10.


Nothing has changed since this bug was originally reported.
Comment 9 Kevin Kofler 2009-03-23 14:46:01 EDT
This also looks wrong in Okular. Reassigning to poppler, which is the library which handles PDF in both Evince and Okular (and is based on xpdf, so it's not surprising they share the same bugs).
Comment 10 James 2009-04-23 04:59:30 EDT
This also affects rawhide: poppler-0.10.5-1.fc11.x86_64. (PDF renders OK in gv.)
Comment 11 Frank Cox 2009-06-11 01:31:42 EDT
The bug is still present in Fedora 11.

Nothing has changed since this bug was originally reported.
Comment 12 Andre Robatino 2009-09-14 11:21:06 EDT
I can reproduce this on i686 with xpdf.  Please change the Platform from "x86_64 Linux" to "All Linux".  In addition, the Version should probably be changed from 11 to rawhide (assuming the bug exists on i686 Rawhide in addition to x86_64, which is almost certainly the case).  Doing this will improve the chances of this being worked on.
Comment 13 Andre Robatino 2009-09-14 11:26:21 EDT
Should have said "I can reproduce this on i686 F11".  Unfortunately, I only have x86_64 Rawhide, so I can't test on i686 Rawhide but since it exists on x86_64 I think it's safe to assume it's also on i686.
Comment 15 Paul Flo Williams 2009-11-05 16:10:23 EST
I've been searching through the FreeDesktop Bugzilla, but I can't find the upstream bug report. We're not relying on telepathy for a resolution, are we?
Comment 16 Frank Cox 2010-03-02 15:19:10 EST
This is apparently not an upstream issue.  I have been advised that the "movie cash" pdf that is attached to this bug report looks just fine with Evince on Ubuntu Karmic using debian package number  Version: 2.28.1-0ubuntu1.2

So whatever the problem appears to have either been solved by the Debian folks and not submitted upstream, or it's a problem specific to Red Hat/Fedora.
Comment 17 Marek Kašík 2010-03-09 07:18:21 EST

the described problem has been fixed in upstream poppler 0.11.1 (actually, it is a feature), which implies that it works in Fedora 12.
But it is a really big patch and it could pull in some regressions, so, I won't backport it into Fedora 11.
I'm closing this with resolution NEXTRELEASE.



For more info see commits e521c1efaeba3f35d10e46bca3d9650dabd2d889,
104f9286ceb5fcb5f4795bca7633029142d5f6a4 and
78a58931b4347ecb505bad5a51104382ef5f91c7 in poppler's git.
Comment 18 Paul Flo Williams 2010-03-09 11:35:40 EST
(In reply to comment #17)
> the described problem has been fixed in upstream poppler 0.11.1 (actually, it
> is a feature), which implies that it works in Fedora 12.

It does indeed! No more black box with up to date F12:

Note You need to log in before you can comment on or make changes to this bug.